Subject: Bug#914860: openjdk-11-jre-headless: fails to install in stretch-backports: ca-certificates-java.postinst: line 56: java: command not found

From: Andreas Beckmann <[email-masked]>
Date: Wed, 28 Nov 2018 03:48:25 +0100

Package: openjdk-11-jre-headless
Version: 11.0.1+13-2~bpo9+1
Severity: important
User: [email-masked]
Usertags: piuparts

Hi,

openjdk-11-jre-headless fails to install in a clean
stretch+stretch-backports environment. There was no previous jre from
stretch installed.

I'm assigning this to openjdk-11-jre-headless/stretch-backports even
though the failing package is ca-certificates-java/stretch, because
this only occurs in stretch-backports in the presence of the newer
package.

[...]
  Setting up ca-certificates-java (20170531+nmu1) ...
  /var/lib/dpkg/info/ca-certificates-java.postinst: line 56: java: command not found
  dpkg: error processing package ca-certificates-java (--configure):
   subprocess installed post-installation script returned error exit status 127
  dpkg: dependency problems prevent configuration of openjdk-11-jre-headless:amd64:
   openjdk-11-jre-headless:amd64 depends on ca-certificates-java; however:
    Package ca-certificates-java is not configured yet.
  
  dpkg: error processing package openjdk-11-jre-headless:amd64 (--configure):
   dependency problems - leaving unconfigured
  dpkg: dependency problems prevent configuration of piuparts-depends-dummy:
   piuparts-depends-dummy depends on ca-certificates-java; however:
    Package ca-certificates-java is not configured yet.
  
  dpkg: error processing package piuparts-depends-dummy (--configure):
   dependency problems - leaving unconfigured
  Processing triggers for libc-bin (2.24-11+deb9u3) ...
  Processing triggers for ca-certificates (20161130+nmu1+deb9u1) ...
  Updating certificates in /etc/ssl/certs...
  0 added, 0 removed; done.
  Running hooks in /etc/ca-certificates/update.d...
  
  /etc/ca-certificates/update.d/jks-keystore: 86: /etc/ca-certificates/update.d/jks-keystore: java: not found
  E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
  done.
  Errors were encountered while processing:
   ca-certificates-java
   openjdk-11-jre-headless:amd64
   piuparts-depends-dummy

Does this require a newer version of ca-certificates-java (needs to
be backported) and a corresponding versioned dependency to work properly?

piuparts did not encounter any problems in either plain stretch or sid.

Andreas

---

From: Andreas Beckmann <[email-masked]>
Date: Sat, 4 May 2019 10:14:00 +0200

Control: found -1 11.0.3+1-1~bpo9+1
Control: affects -1 + openjdk-11-jre openjdk-11-dbg openjdk-11-jre-zero

> be backported) and a corresponding versioned dependency to work properly?

which seems to be ca-certificates-java (>= 20180413)

ca-certificates-java (20180413) unstable; urgency=medium
...
  * Look for Java 10 and Java 11 when detecting the JRE

Please also fix this for sid/buster to prevent partial upgrade paths
that are not working.

Andreas

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Tue, 14 May 2019 16:39:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the openjdk-11-jre-headless package:

#914860: openjdk-11-jre-headless: fails to install in stretch-backports: ca-certificates-java.postinst: line 56: java: command not found

It has been closed by Matthias Klose <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Matthias Klose <[email-masked]> by
replying to this email.

-- 
914860: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=914860
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: Bug#914860: fixed in openjdk-11 11.0.4+2-1
From: Matthias Klose <[email-masked]>
To: [email-masked]
Date: Tue, 14 May 2019 16:37:56 +0000

Source: openjdk-11
Source-Version: 11.0.4+2-1

We believe that the bug you reported is fixed in the latest version of
openjdk-11, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to [email-masked],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Matthias Klose <[email-masked]> (supplier of updated openjdk-11 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email-masked])

Format: 1.8
Date: Tue, 14 May 2019 17:42:59 +0200
Source: openjdk-11
Architecture: source
Version: 11.0.4+2-1
Distribution: unstable
Urgency: medium
Maintainer: OpenJDK Team <[email-masked]>
Changed-By: Matthias Klose <[email-masked]>
Closes: 914860 928369
Changes:
 openjdk-11 (11.0.4+2-1) unstable; urgency=medium
 .
   * OpenJDK 11.0.4+2 build.
   * Fix src.zip symlink. Closes: #928369.
   * Tighten dependency on ca-certificates-java. Closes: #914860.
   * Refresh patches.
Checksums-Sha1:
 d4cce3037789e5af600180a61bcb7ad5ed66bae3 4692 openjdk-11_11.0.4+2-1.dsc
 d5cc2490324daaa4ccf583bae8f714cc68057c08 75356352 openjdk-11_11.0.4+2.orig.tar.xz
 b68becaea82401ed584c9e6666a48c0363d122c4 168492 openjdk-11_11.0.4+2-1.debian.tar.xz
 8a473ce2a1750b535bcea57d15f7911ea214f678 17684 openjdk-11_11.0.4+2-1_source.buildinfo
Checksums-Sha256:
 06a2b09a9d9d441d393820f87445434b8a2f66f25200cbacb57d69ca3ac0ba0c 4692 openjdk-11_11.0.4+2-1.dsc
 4957b349174df485ed149121b2731d611677d8ad5d753c847e0706a6d41d945c 75356352 openjdk-11_11.0.4+2.orig.tar.xz
 3ddbc6226b53601a5f9a74b70c61e95b096327ab2d657e8bd7241683c7893922 168492 openjdk-11_11.0.4+2-1.debian.tar.xz
 b507ad5a32dc151bf5aff1a013179228981dfcfe16d2f4a484cf7b732db44ee3 17684 openjdk-11_11.0.4+2-1_source.buildinfo
Files:
 f03ce1664781852031b68bc71dc10456 4692 java optional openjdk-11_11.0.4+2-1.dsc
 50e217b2abf338004d2adb180320f61e 75356352 java optional openjdk-11_11.0.4+2.orig.tar.xz
 deca48bf7e447a38106ff358fe6c7132 168492 java optional openjdk-11_11.0.4+2-1.debian.tar.xz
 ece8b005488bea6b6e2e09a5503a7e08 17684 java optional openjdk-11_11.0.4+2-1_source.buildinfo

Subject: openjdk-11-jre-headless: fails to install in stretch-backports: ca-certificates-java.postinst: line 56: java: command not found
From: Andreas Beckmann <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Date: Wed, 28 Nov 2018 03:48:25 +0100

Hi,

[...]

  

Andreas

---

From: Andreas Beckmann <[email-masked]>
Date: Sun, 25 Aug 2019 22:46:30 +0200

Followup-For: Bug #914860

The versioned ca-certificates-java dependency was dropped in the most
recent stretch-backports upload, rendering the package uninstallable in
stretch-backports. Please reinstate it and upload a backport of the
required ca-certificates-java, too.

Andreas