Subject: Bug#920903: openjdk-11-jdk-headless: ships documentation for JDK 8, not JDK 11

From: Thorsten Glaser <[email-masked]>
Date: Wed, 30 Jan 2019 14:57:44 +0100

Package: openjdk-11-jdk-headless
Version: 11.0.2+7-1
Severity: important

I saw in https://bugs.openjdk.java.net/browse/JDK-8217581 that
“ (The page for JDK 9 does list correct values.) ” and I was like,
hey, I’ve seen it on my system too!

Turns out that yes.

tglase@tglase:~ $ realpath /usr/share/man/man1/javadoc.1.gz                                                     
/usr/lib/jvm/java-11-openjdk-x32/man/man1/javadoc.1.gz
tglase@tglase:~ $ man -l /usr/lib/jvm/java-11-openjdk-x32/man/man1/javadoc.1.gz 2>/dev/null | tail -1           
JDK 8                            03 March 2015                      javadoc(1)

This is a bug, mismatching documentation that does not document
the installed software correctly is being installed.

-- System Information:
Debian Release: buster/sid
  APT prefers unreleased
  APT policy: (500, 'unreleased'), (500, 'buildd-unstable'), (500, 'unstable')
Architecture: x32 (x86_64)
Foreign Architectures: i386, amd64

Kernel: Linux 4.18.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

Versions of packages openjdk-11-jdk-headless depends on:
ii  libc6                    2.28-5
ii  openjdk-11-jre-headless  11.0.2+7-1
ii  zlib1g                   1:1.2.11.dfsg-1

openjdk-11-jdk-headless recommends no packages.

Versions of packages openjdk-11-jdk-headless suggests:
pn  openjdk-11-demo    <none>
ii  openjdk-11-source  11.0.2+7-1

-- no debconf information

---

From: Etienne Dysli Metref <[email-masked]>
Date: Mon, 10 Aug 2020 12:49:19 +0200

Hi there!

As a Java developer, I'm very much interested in having this bug
fixed. It has already caused me to give wrong information to other
people... :/ For example: the java(1) man page lists the option
`-XX:+HeapDumpOnOutOfMemory`, but this option has been renamed to
`-XX:+HeapDumpOnOutOfMemoryError` in Java 11.

Is this a Debian packaging problem or does upstream provide the wrong
documentation?

Let me know if I can help fix this, I know Debian packaging a bit.

Cheers,
  Etienne

---

From: Matthias Klose <[email-masked]>
Date: Mon, 10 Aug 2020 13:17:59 +0200

> Is this a Debian packaging problem or does upstream provide the wrong

that's the documentation provided by upstream.

---

From: Etienne Dysli Metref <[email-masked]>
Date: Mon, 10 Aug 2020 14:11:22 +0200

> that's the documentation provided by upstream.

Thank you for the fast answer Matthias. :)
Would https://bugs.openjdk.java.net/browse/JDK-8225134 be the
corresponding upstream issue? Is there any hope this could be fixed in a
future OpenJDK 11 release?

  Etienne

---

From: Matthias Klose <[email-masked]>
Date: Mon, 10 Aug 2020 14:17:06 +0200

On 8/10/20 2:11 PM, Etienne Dysli Metref wrote:
> corresponding upstream issue?

That's the issue for 13, not 11.

> Is there any hope this could be fixed in a

if somebody updates those for 11 ...

---

From: Etienne Dysli Metref <[email-masked]>
Date: Mon, 10 Aug 2020 15:23:08 +0200

> if somebody updates those for 11 ...

I'd happily file an upstream bug to prod them, but I can't get the form
at https://bugreport.java.com/bugreport/start_form.do to work... :(

  Etienne

---

From: Etienne Dysli Metref <[email-masked]>
Date: Wed, 19 Aug 2020 08:41:01 +0200

forwarded 920903 https://bugs.openjdk.java.net/browse/JDK-8251572
thanks

On 10/08/2020 14.17, Matthias Klose wrote:
>> Is there any hope this could be fixed in a future OpenJDK 11
>> release?
>
I managed to report this bug to Oracle, so it might increase the
chances of someone eventually fixing it. :)

Cheers
  Etienne