Subject: planner: segfaulted; now segfaults on every start-up

From: Jonathan Dowland <[email-masked]>
Date: Fri, 26 Apr 2019 12:16:02 +0100

Package: planner
Version: 0.14.6-7
Severity: important

planner segfaulted me shortly after starting it for the first time
(upon inserting a new task); now, it segfaults upon each attempt to
start it.

▶ planner
Gtk-Message: 12:10:14.171: Failed to load module "canberra-gtk-module"

(planner:13551): GLib-GObject-CRITICAL **: 12:10:14.318: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(planner:13551): GLib-GObject-WARNING **: 12:10:14.319: invalid unclassed pointer in cast to 'GDelayedSettingsBackend'

(planner:13551): GLib-GObject-WARNING **: 12:10:14.319: invalid unclassed pointer in cast to 'GSettingsBackend'

(planner:13551): GLib-GIO-CRITICAL **: 12:10:14.319: g_settings_backend_path_changed: assertion 'G_IS_SETTINGS_BACKEND (backend)' failed

(planner:13551): GLib-GObject-CRITICAL **: 12:10:14.319: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
**
GLib-GObject:ERROR:../../../gobject/gobject.c:4447:g_weak_ref_set: assertion failed: (weak_locations != NULL)
Aborted (core dumped)

▶ gdb $(which planner) core
GNU gdb (Debian 8.2.1-2) 8.2.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/planner...Reading symbols from /usr/lib/debug/.build-id/9c/0b4d0a054dc7d4d8e82b55d1663930716ae3f9.debug...done.
done.
[New LWP 13554]
[New LWP 13551]
[New LWP 13553]
[New LWP 13552]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `planner'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007fc3e7ed98bb in raise () from /lib/x86_64-linux-gnu/libc.so.6
[Current thread is 1 (Thread 0x7fc3e20cd700 (LWP 13554))]
(gdb) bt
#0  0x00007fc3e7ed98bb in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007fc3e7ec4535 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007fc3e8222dc3 in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, 
    func=0x7fc3e83662e8 <__FUNCTION__.15331> "g_weak_ref_set", message=<optimized out>) at ../../../glib/gtestutils.c:2596
#3  0x00007fc3e827c68a in g_assertion_message_expr (domain=domain@entry=0x7fc3e8363078 "GLib-GObject", 
    file=file@entry=0x7fc3e836528e "../../../gobject/gobject.c", line=line@entry=4447, 
    func=func@entry=0x7fc3e83662e8 <__FUNCTION__.15331> "g_weak_ref_set", 
    expr=expr@entry=0x7fc3e836570a "weak_locations != NULL") at ../../../glib/gtestutils.c:2619
#4  0x00007fc3e8341b26 in g_weak_ref_set (weak_ref=0x55e169ffe290, object=0x0) at ../../../gobject/gobject.c:4447
#5  0x00007fc3e8341b7b in g_weak_ref_clear (weak_ref=0x55e169ffe290) at ../../../gobject/gobject.c:4350
#6  0x00007fc3e84a6217 in g_settings_backend_invoke_closure (user_data=0x7fc3d806c040) at ../../../gio/gsettingsbackend.c:275
#7  0x00007fc3e84a6370 in g_settings_backend_dispatch_signal (backend=0x55e169c595d0, function_offset=8, 
    name=0x55e169fec000 "/org/gnome/planner/views/task-view/wbs/", origin_tag=0x0, names=0x0)
    at ../../../gio/gsettingsbackend.c:334
#8  0x00007fc3e3657f09 in dconf_engine_watch_established (reply=<optimized out>, error=<optimized out>, 
    handle=0x55e169fbf910, engine=0x55e169be6140) at ../engine/dconf-engine.c:963
#9  dconf_engine_watch_established (engine=0x55e169be6140, handle=0x55e169fbf910, reply=<optimized out>, 
    error=<optimized out>) at ../engine/dconf-engine.c:938
#10 0x00007fc3e365abec in dconf_gdbus_method_call_done (source=<optimized out>, result=<optimized out>, 
    user_data=user_data@entry=0x55e169fbf910) at ../gdbus/dconf-gdbus-thread.c:254
#11 0x00007fc3e8469719 in g_task_return_now (task=0x7fc3d80588d0) at ../../../gio/gtask.c:1148
#12 0x00007fc3e846a196 in g_task_return (task=0x7fc3d80588d0, type=<optimized out>) at ../../../gio/gtask.c:1206
#13 0x00007fc3e84bfb1a in g_dbus_connection_call_done (source=<optimized out>, result=0x7fc3d8009930, 
    user_data=user_data@entry=0x7fc3d80588d0) at ../../../gio/gdbusconnection.c:5715
#14 0x00007fc3e8469719 in g_task_return_now (task=0x7fc3d8009930) at ../../../gio/gtask.c:1148
#15 0x00007fc3e8469759 in complete_in_idle_cb (task=0x7fc3d8009930) at ../../../gio/gtask.c:1162
#16 0x00007fc3e8254dd8 in g_main_dispatch (context=0x55e169c6c160) at ../../../glib/gmain.c:3182
#17 g_main_context_dispatch (context=context@entry=0x55e169c6c160) at ../../../glib/gmain.c:3847
#18 0x00007fc3e82551c8 in g_main_context_iterate (context=context@entry=0x55e169c6c160, block=block@entry=1, 
    dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:3920
#19 0x00007fc3e825525c in g_main_context_iteration (context=context@entry=0x55e169c6c160, may_block=may_block@entry=1)
    at ../../../glib/gmain.c:3981
#20 0x00007fc3e365affd in dconf_gdbus_worker_thread (user_data=0x55e169c6c160) at ../gdbus/dconf-gdbus-thread.c:82
#21 0x00007fc3e827d425 in g_thread_proxy (data=0x55e169b45c00) at ../../../glib/gthread.c:784
#22 0x00007fc3e806afa3 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#23 0x00007fc3e7f9b82f in clone () from /lib/x86_64-linux-gnu/libc.so.6

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'testing-debug'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-1-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_WARN
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages planner depends on:
ii  libart-2.0-2         2.3.21-4
ii  libatk1.0-0          2.30.0-2
ii  libc6                2.28-8
ii  libcairo2            1.16.0-4
ii  libgdk-pixbuf2.0-0   2.38.1+dfsg-1
ii  libglade2-0          1:2.6.4-2+b1
ii  libglib2.0-0         2.58.3-1
ii  libgnomecanvas2-0    2.30.3-4
ii  libgtk2.0-0          2.24.32-3
ii  libpango-1.0-0       1.42.4-6
ii  libpangocairo-1.0-0  1.42.4-6
ii  libpython2.7         2.7.16-1
ii  libxml2              2.9.4+dfsg1-7+b3
ii  libxslt1.1           1.1.32-2
ii  planner-data         0.14.6-7
ii  python               2.7.16-1
ii  shared-mime-info     1.10-1

Versions of packages planner recommends:
ii  gconf2       3.2.6-5
ii  planner-doc  0.14.6-7

planner suggests no packages.

-- no debconf information

---

From: Yavor Doganov <[email-masked]>
Date: Sat, 27 Apr 2019 09:07:03 +0300

Control: tags -1 + unreproducible moreinfo

> (upon inserting a new task); now, it segfaults upon each attempt to

Thanks for the report; unfortunately I cannot reproduce it.  And
that's an abort, not segfault.  Could you please run the planner
executable in gdb with --g-fatal-warnings?

---

From: Jonathan Dowland <[email-masked]>
Date: Fri, 17 May 2019 11:33:41 +0100

>executable in gdb with --g-fatal-warnings?

Sorry for mixing the two up. Here's a trace with --g-fatal-warnings.
ON this occasion the crash happened when I attempted to resize the
window.  Some additional context:  was running in a GNOME/Wayland
session. I'm going to try GNOME/Xorg now.

Trace:

(gdb) set args --g-fatal-warnings
(gdb) run
Starting program: /usr/bin/planner --g-fatal-warnings
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Gtk-Message: 11:16:05.042: Failed to load module "canberra-gtk-module"
[New Thread 0x7ffff2281700 (LWP 24278)]
[New Thread 0x7ffff1a80700 (LWP 24279)]
[New Thread 0x7ffff120c700 (LWP 24280)]
[New Thread 0x7fffe3a76700 (LWP 24284)]
[New Thread 0x7fffe3275700 (LWP 24285)]
[New Thread 0x7fffe250c700 (LWP 24286)]
[New Thread 0x7fffe1d0b700 (LWP 24287)]
[Thread 0x7fffe250c700 (LWP 24286) exited]
[Thread 0x7fffe3275700 (LWP 24285) exited]
[Thread 0x7fffe1d0b700 (LWP 24287) exited]
[New Thread 0x7fffe1d0b700 (LWP 24288)]
[New Thread 0x7fffe250c700 (LWP 24289)]
[Thread 0x7fffe1d0b700 (LWP 24288) exited]
[Thread 0x7fffe250c700 (LWP 24289) exited]
[Thread 0x7fffe3a76700 (LWP 24284) exited]

(planner:24274): GLib-GObject-CRITICAL **: 11:30:58.399: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

Thread 4 "dconf worker" received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0x7ffff120c700 (LWP 24280)]
0x00007ffff735bca5 in _g_log_abort (breakpoint=1) at ../../../glib/gmessages.c:554
554	../../../glib/gmessages.c: No such file or directory.
(gdb) bt
#0  0x00007ffff735bca5 in _g_log_abort (breakpoint=1) at ../../../glib/gmessages.c:554
#1  0x00007ffff735cfad in g_logv
    (log_domain=0x7ffff7464078 "GLib-GObject", log_level=G_LOG_LEVEL_CRITICAL, format=<optimized out>, args=args@entry=0x7ffff120b840) at ../../../glib/gmessages.c:1371
#2  0x00007ffff735d17f in g_log
    (log_domain=log_domain@entry=0x7ffff7464078 "GLib-GObject", log_level=log_level@entry=G_LOG_LEVEL_CRITICAL, format=format@entry=0x7ffff73ab6bc "%s: assertion '%s' failed") at ../../../glib/gmessages.c:1413
#3  0x00007ffff735d9a9 in g_return_if_fail_warning
    (log_domain=log_domain@entry=0x7ffff7464078 "GLib-GObject", pretty_function=pretty_function@entry=0x7ffff74675f8 <__FUNCTION__.14906> "g_object_ref", expression=expression@entry=0x7ffff74663bf "G_IS_OBJECT (object)")
    at ../../../glib/gmessages.c:2762
#4  0x00007ffff743ca3c in g_object_ref (_object=0x555555d00f00) at ../../../gobject/gobject.c:3212
#5  0x00007ffff74429b5 in g_weak_ref_get (weak_ref=<optimized out>) at ../../../gobject/gobject.c:4387
#6  0x00007ffff75a71d2 in g_settings_backend_invoke_closure (user_data=0x555555c9f740)
    at ../../../gio/gsettingsbackend.c:263
#7  0x00007ffff75a7370 in g_settings_backend_dispatch_signal
    (backend=0x5555556a9610 [DConfSettingsBackend], function_offset=8, name=0x555555c20f10 "/org/gnome/planner/views/task-view/assigned-to/", origin_tag=0x0, names=0x0) at ../../../gio/gsettingsbackend.c:334
#8  0x00007ffff275df09 in dconf_engine_watch_established
    (reply=<optimized out>, error=<optimized out>, handle=0x555555abea40, engine=0x5555556f3950)
    at ../engine/dconf-engine.c:963
#9  0x00007ffff275df09 in dconf_engine_watch_established
    (engine=0x5555556f3950, handle=0x555555abea40, reply=<optimized out>, error=<optimized out>)
    at ../engine/dconf-engine.c:938
#10 0x00007ffff2760bec in dconf_gdbus_method_call_done
    (source=<optimized out>, result=<optimized out>, user_data=user_data@entry=0x555555abea40)
    at ../gdbus/dconf-gdbus-thread.c:254
#11 0x00007ffff756a719 in g_task_return_now (task=0x7fffe80651e0 [GTask]) at ../../../gio/gtask.c:1148
#12 0x00007ffff756b196 in g_task_return (task=0x7fffe80651e0 [GTask], type=<optimized out>)
    at ../../../gio/gtask.c:1206
#13 0x00007ffff75c0b1a in g_dbus_connection_call_done
--Type <RET> for more, q to quit, c to continue without paging--
    (source=<optimized out>, result=0x7fffe804b840, user_data=user_data@entry=0x7fffe80651e0)
    at ../../../gio/gdbusconnection.c:5715
#14 0x00007ffff756a719 in g_task_return_now (task=0x7fffe804b840 [GTask]) at ../../../gio/gtask.c:1148
#15 0x00007ffff756a759 in complete_in_idle_cb (task=0x7fffe804b840) at ../../../gio/gtask.c:1162
#16 0x00007ffff7355dd8 in g_main_dispatch (context=0x555555717a00) at ../../../glib/gmain.c:3182
#17 0x00007ffff7355dd8 in g_main_context_dispatch (context=context@entry=0x555555717a00) at ../../../glib/gmain.c:3847
#18 0x00007ffff73561c8 in g_main_context_iterate
    (context=context@entry=0x555555717a00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at ../../../glib/gmain.c:3920
#19 0x00007ffff735625c in g_main_context_iteration (context=context@entry=0x555555717a00, may_block=may_block@entry=1)
    at ../../../glib/gmain.c:3981
#20 0x00007ffff2760ffd in dconf_gdbus_worker_thread (user_data=0x555555717a00) at ../gdbus/dconf-gdbus-thread.c:82
#21 0x00007ffff737e425 in g_thread_proxy (data=0x555555651000) at ../../../glib/gthread.c:784
#22 0x00007ffff716bfa3 in start_thread () at /lib/x86_64-linux-gnu/libpthread.so.0
#23 0x00007ffff709c4cf in clone () at /lib/x86_64-linux-gnu/libc.so.6

---

From: Jonathan Dowland <[email-masked]>
Date: Fri, 17 May 2019 11:37:19 +0100

On Fri, May 17, 2019 at 11:33:41AM +0100, Jonathan Dowland wrote:
>Some additional context:  was running in a GNOME/Wayland

Actually i mave have already been in GNOME/Xorg rather than Wayland,
unfortunately I cannot be sure now. The following happened on my next attempt
to use planner, definitely in an Xorg session this time. I did not set the
--g-* argument. SEGV happened when editing a text field "Name" in the "edit task"
dialog.

(gdb) run
Starting program: /usr/bin/planner 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Gtk-Message: 11:34:31.593: Failed to load module "canberra-gtk-module"
[New Thread 0x7ffff2281700 (LWP 29894)]
[New Thread 0x7ffff1a80700 (LWP 29895)]
[New Thread 0x7ffff120c700 (LWP 29898)]

Thread 1 "planner" received signal SIGSEGV, Segmentation fault.
g_type_check_instance_is_fundamentally_a (type_instance=type_instance@entry=0x7fffe8094080, 
    fundamental_type=fundamental_type@entry=0x50 [GObject]) at ../../../gobject/gtype.c:4026
4026	../../../gobject/gtype.c: No such file or directory.
(gdb) bt
#0  0x00007ffff745c51f in g_type_check_instance_is_fundamentally_a
    (type_instance=type_instance@entry=0x7fffe8094080, fundamental_type=fundamental_type@entry=0x50 [GObject])
    at ../../../gobject/gtype.c:4026
#1  0x00007ffff743ca1e in g_object_ref (_object=0x7fffe8094080) at ../../../gobject/gobject.c:3212
#2  0x00007ffff74429b5 in g_weak_ref_get (weak_ref=<optimized out>) at ../../../gobject/gobject.c:4387
#3  0x00007ffff75a71d2 in g_settings_backend_invoke_closure (user_data=0x7fffe80a9800)
    at ../../../gio/gsettingsbackend.c:263
#4  0x00007ffff7355dd8 in g_main_dispatch (context=0x555555642c00) at ../../../glib/gmain.c:3182
#5  0x00007ffff7355dd8 in g_main_context_dispatch (context=context@entry=0x555555642c00) at ../../../glib/gmain.c:3847
#6  0x00007ffff73561c8 in g_main_context_iterate
    (context=0x555555642c00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at ../../../glib/gmain.c:3920
#7  0x00007ffff73564c2 in g_main_loop_run (loop=0x555555a898d0) at ../../../glib/gmain.c:4116
#8  0x00007ffff79ef8e7 in gtk_main () at /lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#9  0x0000555555570bae in main ()

---

From: Bill Wohler <[email-masked]>
Date: Thu, 16 Jul 2020 07:20:49 -0700

I fired up planner 0.14.6-7 for the first time since my buster update
and this same issue is happening constantly.

I think you should be able to reproduce it reliably by moving the window
to the upper left-hand corner for example and resizing the lower
right-hand corner to the lower right-hand corner of your desktop. If it
hasn't crashed already, while still resizing, move the mouse in circles.

In the meantime, I'm avoiding resizing the window and saving every time
I make a change and running planner in a while loop in the shell to make
the program somewhat usable.

Yavor Doganov <[email-masked]> wrote:

> Reply-To: Yavor Doganov <[email-masked]>, [email-masked]
> Date: Sat, 27 Apr 2019 09:07:03 +0300
> To: Jonathan Dowland <[email-masked]>,
> 	[email-masked]
>
> Jonathan Dowland wrote:
> > Package: planner
> > Version: 0.14.6-7
> > Severity: important
> > 

-- 
Bill Wohler <[email-masked]> aka <[email-masked]>
http://www.newt.com/wohler/, GnuPG ID:610BD9AD