Subject: Bug#931280: gnome-shell: Keyboard layout randomly alternates

From: Paul Menzel <[email-masked]>
Date: Sun, 30 Jun 2019 14:35:47 +0200

Package: gnome-shell
Version: 3.30.2-9
Severity: serious

Dear Debian folks,

With Debian Sid/unstable with the default GNOME session, that means 
Wayland is used, and with two keyboard layouts configured (Neo 
(default), and German) sometimes the keyboard layout changes from Neo to 
normal German without me pressing the corresponding shortcut. The 
notification in the GNOME Shell’s top bar also still shows de₁, which is 
for Deutsch (Neo 2), so it is not changed.

Unfortunnately I have not figured out, what causes this. My suspicion is 
that “X.Org applications” like Mozilla Firefox and Thunderbird are 
involved. Maybe the GDM session running in parallel has something to do 
with it? No idea.

Debugging help is much appreciated.

Kind regards,

Paul

PS: I chose the severity *serious*, because suddenly having a different 
keyboard layout can cause data loss, when you suddenly press key which
for example confirms the deletion of data, despite you thinking you
press a different key to abort on the keyboard you currently use.

-- System Information:
Debian Release: 10.0
   APT prefers unstable-debug
   APT policy: (500, 'unstable-debug'), (500, 'unstable'), (1, 
'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), 
LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-shell depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.30.1-2
ii  evolution-data-server                        3.30.5-1
ii  gir1.2-accountsservice-1.0                   0.6.45-2
ii  gir1.2-atspi-2.0                             2.30.0-7
ii  gir1.2-freedesktop                           1.58.3-2
ii  gir1.2-gcr-3                                 3.28.1-1
ii  gir1.2-gdesktopenums-3.0                     3.28.1-1
ii  gir1.2-gdm-1.0                               3.30.2-3
ii  gir1.2-geoclue-2.0                           2.5.2-1
ii  gir1.2-glib-2.0                              1.58.3-2
ii  gir1.2-gnomebluetooth-1.0                    3.28.2-3
ii  gir1.2-gnomedesktop-3.0                      3.30.2.1-2
ii  gir1.2-gtk-3.0                               3.24.5-1
ii  gir1.2-gweather-3.0                          3.28.3-1
ii  gir1.2-ibus-1.0                              1.5.19-4+b1
ii  gir1.2-mutter-3                              3.30.2-7
ii  gir1.2-nm-1.0                                1.14.6-2
ii  gir1.2-nma-1.0                               1.8.20-1.1
ii  gir1.2-pango-1.0                             1.42.4-6
ii  gir1.2-polkit-1.0                            0.105-25
ii  gir1.2-rsvg-2.0                              2.44.10-2.1
ii  gir1.2-soup-2.4                              2.64.2-2
ii  gir1.2-upowerglib-1.0                        0.99.10-1
ii  gjs                                          1.54.3-1
ii  gnome-backgrounds                            3.30.0-1
ii  gnome-settings-daemon                        3.30.2-3
ii  gnome-shell-common                           3.30.2-9
ii  gsettings-desktop-schemas                    3.28.1-1
ii  libatk-bridge2.0-0                           2.30.0-5
ii  libatk1.0-0                                  2.30.0-2
ii  libc6                                        2.28-10
ii  libcairo2                                    1.16.0-4
ii  libcanberra-gtk3-0                           0.30-7
ii  libcanberra0                                 0.30-7
ii  libcroco3                                    0.6.12-3
ii  libecal-1.2-19                               3.30.5-1
ii  libedataserver-1.2-23                        3.30.5-1
ii  libgcr-base-3-1                              3.28.1-1
ii  libgdk-pixbuf2.0-0                           2.38.1+dfsg-1
ii  libgirepository-1.0-1                        1.58.3-2
ii  libgjs0g                                     1.54.3-1
ii  libglib2.0-0                                 2.58.3-2
ii  libglib2.0-bin                               2.58.3-2
ii  libgstreamer1.0-0                            1.14.4-1
ii  libgtk-3-0                                   3.24.5-1
ii  libical3                                     3.0.5-1
ii  libjson-glib-1.0-0                           1.4.4-2
ii  libmutter-3-0                                3.30.2-7
ii  libnm0                                       1.14.6-2
ii  libpango-1.0-0                               1.42.4-6
ii  libpangocairo-1.0-0                          1.42.4-6
ii  libpolkit-agent-1-0                          0.105-25
ii  libpolkit-gobject-1-0                        0.105-25
ii  libpulse-mainloop-glib0                      12.2-4
ii  libpulse0                                    12.2-4
ii  libsecret-1-0                                0.18.7-1
ii  libstartup-notification0                     0.12-6
ii  libsystemd0                                  242+git20190613-1
ii  libx11-6                                     2:1.6.7-1
ii  libxfixes3                                   1:5.0.3-1
ii  mutter                                       3.30.2-7
ii  python3                                      3.7.3-1

Versions of packages gnome-shell recommends:
ii  bolt                  0.7-2
ii  chrome-gnome-shell    10.1-5
ii  gdm3                  3.30.2-3
ii  gkbd-capplet          3.26.1-1
ii  gnome-control-center  1:3.30.3-1
ii  gnome-user-docs       3.30.2-1
ii  iio-sensor-proxy      2.4-2
ii  switcheroo-control    1.2-2
ii  unzip                 6.0-23

Versions of packages gnome-shell suggests:
pn  gir1.2-telepathyglib-0.12   <none>
pn  gir1.2-telepathylogger-0.2  <none>

-- no debconf information

---

From: Michael Biebl <[email-masked]>
Date: Sun, 30 Jun 2019 15:58:50 +0200

> Severity: serious

That feels vastly exaggerated. That aside...

> Debugging help is much appreciated.

I too have two keyboard layouts configured and this happens to me as
well, under GNOME/Xorg and afaics is simply me pressing by accident
Windows/Super + Space. This is the shortcut for switching the keyboard
layout.
I suspect it's the same for you.
You can reconfigure the shortcut in gnome-control-center.
Go to "Tastatur->Texteingabe->Zur nächsten Quelle wechseln"

-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

---

From: Paul Menzel <[email-masked]>
Date: Mon, 1 Jul 2019 10:29:39 +0200

Severity: normal

On 30.06.19 15:58, Michael Biebl wrote:
> On Sun, 30 Jun 2019 14:35:47 +0200 Paul Menzel wrote:
>> Package: gnome-shell
>> Version: 3.30.2-9
>> Severity: serious
> 

Ok, if you say so that it won’t cause data loss. I change it to *normal*.

>> Unfortunately I have not figured out, what causes this. My suspicion is

I am pretty sure, it’s not it, because if I press this shortcut, a popup 
is shown and the notification in the top bar changes.

Kind regards,

Paul

---

From: Michael Biebl <[email-masked]>
Date: Mon, 1 Jul 2019 13:31:10 +0200

> is shown and the notification in the top bar changes.

I only get this pop-up as long as I press Super. Once I release Super,
the popup is gone. If I do that quickly, then the popup is never shown here.
That said, my status indicator (in the upper right corner, I guess
that's what you meant with notification) *does* change.
So your case might be different indeed.
I just wanted to rule out the most obvious (e.g. by disabling this
shortcut temporarily)

Regards

---

From: Ivo De Decker <[email-masked]>
Date: Wed, 17 Mar 2021 17:13:46 +0100

> Severity: normal
severity 931280 normal
thanks

Ivo