Subject: Bug#933293: /usr/bin/debchange: dch: any and all uploads to experimental should have urgency=low

From: Thorsten Glaser <[email-masked]>
Date: Sun, 28 Jul 2019 21:15:11 +0200

Package: devscripts
Version: 2.19.5
Severity: normal
File: /usr/bin/debchange

Due to #831699 any and all uploads to experimental should have
“urgency=low”.

Please adjust the default urgency for things like “dch -i”,
“dch --qa”, “dch --team”, etc. when the previous upload was
to experimental already and/or the distribution is set to
experimental, o̲r̲ consider reverting the change of the default
urgency to medium.

-- Package-specific info:

--- /etc/devscripts.conf ---

--- ~/.devscripts ---
DEBCHANGE_AUTO_NMU=no
DEBCHANGE_MAINTTRAILER=no
DEBCHANGE_MULTIMAINT_MERGE=yes
DEBCHANGE_RELEASE_HEURISTIC=log

-- System Information:
Debian Release: 10.0
  APT prefers buildd-unstable
  APT policy: (500, 'buildd-unstable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

Versions of packages devscripts depends on:
ii  dpkg-dev              1.19.7
ii  fakeroot              1.23-1
ii  file                  1:5.35-4
ii  gnupg                 2.2.13-2
ii  gnupg2                2.2.13-2
ii  gpgv                  2.2.13-2
ii  libc6                 2.28-10
ii  libfile-homedir-perl  1.004-1
ii  libfile-which-perl    1.23-1
ii  libipc-run-perl       20180523.0-1
ii  libmoo-perl           2.003004-2
ii  libwww-perl           6.36-2
ii  patchutils            0.3.4-2
ii  perl                  5.28.1-6
ii  python3               3.7.3-1
ii  sensible-utils        0.0.12
ii  wdiff                 1.2.2-2+b1

Versions of packages devscripts recommends:
ii  apt                         1.8.2
ii  at                          3.1.23-1
ii  curl                        7.64.0-4
ii  dctrl-tools                 2.24-3
ii  debian-keyring              2019.06.25
ii  dput                        1.0.3
ii  equivs                      2.2.0
pn  libdistro-info-perl         <none>
ii  libdpkg-perl                1.19.7
ii  libencode-locale-perl       1.05-1
pn  libgit-wrapper-perl         <none>
pn  libgitlab-api-v4-perl       <none>
pn  liblist-compare-perl        <none>
ii  liblwp-protocol-https-perl  6.07-2
pn  libsoap-lite-perl           <none>
pn  libstring-shellquote-perl   <none>
ii  libtry-tiny-perl            0.30-1
ii  liburi-perl                 1.76-1
pn  licensecheck                <none>
ii  lintian                     2.15.0
ii  man-db                      2.8.5-2
ii  patch                       2.7.6-4
ii  python3-apt                 1.8.4
ii  python3-debian              0.1.35
ii  python3-magic               2:0.4.15-2
ii  python3-requests            2.21.0-1
pn  python3-unidiff             <none>
pn  python3-xdg                 <none>
ii  strace                      4.26-0.2
ii  unzip                       6.0-23
ii  wget                        1.20.1-1.1
ii  xz-utils                    5.2.4-1

Versions of packages devscripts suggests:
ii  adequate                                  0.15.2
pn  autopkgtest                               <none>
pn  bls-standalone                            <none>
ii  bsd-mailx [mailx]                         8.1.2-0.20180807cvs-1
ii  build-essential                           12.6
pn  check-all-the-things                      <none>
pn  cvs-buildpackage                          <none>
ii  debhelper                                 12.1.1
pn  devscripts-el                             <none>
ii  diffoscope                                116
pn  disorderfs                                <none>
pn  dose-extra                                <none>
pn  duck                                      <none>
pn  faketime                                  <none>
pn  gnuplot                                   <none>
pn  how-can-i-help                            <none>
pn  libauthen-sasl-perl                       <none>
ii  libdbd-pg-perl                            3.7.4-3
pn  libfile-desktopentry-perl                 <none>
pn  libnet-smtps-perl                         <none>
pn  libterm-size-perl                         <none>
ii  libtimedate-perl                          2.3000-2
ii  libyaml-syck-perl                         1.31-1+b1
pn  mozilla-devscripts                        <none>
pn  mutt                                      <none>
ii  openssh-client [ssh-client]               1:7.9p1-10
pn  piuparts                                  <none>
ii  postgresql-client-11 [postgresql-client]  11.4-1
ii  quilt                                     0.65-3
pn  ratt                                      <none>
pn  reprotest                                 <none>
pn  svn-buildpackage                          <none>
ii  w3m                                       0.5.3-37

-- no debconf information

---

From: Mattia Rizzolo <[email-masked]>
Date: Mon, 19 Aug 2019 16:14:35 +0200

> experimental, o̲r̲ consider reverting the change of the default

The default change was requested by the release team, so that very much
won't change. (#730343).

-- 
regards,
                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18  4D18 4B04 3FCD B944 4540      .''`.
more about me:  https://mapreri.org                             : :'  :
Launchpad user: https://launchpad.net/~mapreri                  `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia  `-

---

From: Thorsten Glaser <[email-masked]>
Date: Mon, 19 Aug 2019 14:32:19 +0000 (UTC)

>The default change was requested by the release team, so that very much

That’s for uploads to unstable, not to experimental.

I’m sure the release team won’t argue against my requested change
(defaulting to low for experimental, as no upload to experimental
should use a different urgency due to #831699). I’m adding those
involved in #730343 to the Cc list, so they will know.

Thanks,
//mirabilos
-- 
<igli> exceptions: a truly awful implementation of quite a nice idea.
<igli> just about the worst way you could do something like that, afaic.
<igli> it's like anti-design.  <mirabilos> that too… may I quote you on that?
<igli> sure, tho i doubt anyone will listen ;)

---

From: Mattia Rizzolo <[email-masked]>
Date: Mon, 19 Aug 2019 16:50:45 +0200

> That’s for uploads to unstable, not to experimental.

Yes, but you said "or consider reverting the change of the default
urgency to medium".  I'm saying that bit won't be done.

> (defaulting to low for experimental

Yes, that's possible.

-- 
regards,
                        Mattia Rizzolo

---

From: Jonathan Wiltshire <[email-masked]>
Date: Tue, 20 Aug 2019 20:24:14 +0100

Hi,

I have no idea why I'm in CC for this bug, but please don't. I don't have
any opinion about urgency in experimental, I don't maintain devscripts,
and picking random members of the release team to contact is not scalable.
We have team contact addresses for that.

Thanks,

-- 
Jonathan Wiltshire                                      [email-masked]
Debian Developer                         http://people.debian.org/~jmw

4096R: 0xD3524C51 / 0A55 B7C5 1223 3942 86EC  74C3 5394 479D D352 4C51

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Tue, 20 Aug 2019 19:27:06 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #933293.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
933293: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933293
Debian Bug Tracking System
Contact [email-masked] with problems