Subject: Bug#942127: bugs in the FILTER EXPRESSIONS section of the gpg man page

From: Steve McIntyre <[email-masked]>
Date: Thu, 10 Oct 2019 18:42:28 +0100

Package: gpg
Version: 2.2.12-1+deb10u1
Severity: minor
Tags: upstream

Hi!

I'm trying to use --import-filter with gpg. the man page directs me to
the FILTER EXPRESSIONS section for more details. The examples there
use the text:

                 --import-option keep-uid="uid =~ Alfa"
                 --import-option keep-uid="&& uid !~ Test"
                 --import-option keep-uid="|| uid =~ Alpha"
                 --import-option keep-uid="uid !~ Test"

which clearly should be 

                 --import-filter keep-uid="uid =~ Alfa"
                 --import-filter keep-uid="&& uid !~ Test"
                 --import-filter keep-uid="|| uid =~ Alpha"
                 --import-filter keep-uid="uid !~ Test"

Looks like a simple cut and paste / completion error.

-- System Information:
Debian Release: 10.1
  APT prefers stable-debug
  APT policy: (500, 'stable-debug'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-6-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gpg depends on:
ii  gpgconf        2.2.12-1+deb10u1
ii  libassuan0     2.5.2-1
ii  libbz2-1.0     1.0.6-9.2~deb10u1
ii  libc6          2.28-10
ii  libgcrypt20    1.8.4-5
ii  libgpg-error0  1.35-1
ii  libreadline7   7.0-5
ii  libsqlite3-0   3.27.2-3
ii  zlib1g         1:1.2.11.dfsg-1

Versions of packages gpg recommends:
ii  gnupg  2.2.12-1+deb10u1

gpg suggests no packages.

-- no debconf information

---

From: Werner Koch <[email-masked]>
Date: Sat, 12 Oct 2019 12:34:57 +0200

> Looks like a simple cut and paste / completion error.

Now fixed upstream.  Thanks for reporting.

Shalom-Salam,

   Werner

-- 
Die Gedanken sind frei.  Ausnahmen regelt ein Bundesgesetz.