Subject: /lib/systemd/system/fwupd-refresh.service: Re: fwupd: fwupd-refresh.service failed to start Refresh fwupd metadata and update motd.

From: Alban Browaeys <[email-masked]>
Date: Mon, 27 Dec 2021 17:16:48 +0100

Package: fwupd
Version: 1.5.7-4
Followup-For: Bug #943343

Dear Maintainer,

Note that with an old system with libnss-systemd installed my /etc/nssswitch.conf
 was missing systemd for passwd and group lines. Be it per manual change or my system being
an upgrade from pre stretch time, libnss-systemd only adds the systemd entries to these lines
on the first install.
So a note in the README of the package that this entry is required on those lines seems required, at least
if having an nsswitch.conf customized is supported by Debian.

Cheers,
Alban

-- System Information:
Debian Release: 11.2
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable-debug'), (500, 'stable'), (90, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.10.0-10-amd64 (SMP w/4 CPU threads)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages fwupd depends on:
ii  libc6                  2.31-13+deb11u2
ii  libcurl3-gnutls        7.74.0-1.3+deb11u1
ii  libefiboot1            37-6
ii  libelf1                0.183-1
ii  libflashrom1           1.2-5
ii  libfwupd2              1.5.7-4
ii  libfwupdplugin1        1.5.7-4
ii  libglib2.0-0           2.66.8-1
ii  libgnutls30            3.7.1-5
ii  libgudev-1.0-0         234-1
ii  libgusb2               0.3.5-1
ii  libjcat1               0.1.3-2
ii  libjson-glib-1.0-0     1.6.2-1
ii  libpolkit-gobject-1-0  0.105-31
ii  libsmbios-c2           2.4.3-1
ii  libsqlite3-0           3.34.1-3
ii  libsystemd0            247.3-6
ii  libtss2-esys-3.0.2-0   3.0.3-2
ii  libxmlb1               0.1.15-2
ii  shared-mime-info       2.0-1

Versions of packages fwupd recommends:
ii  bolt                               0.9.1-1
ii  dbus                               1.12.20-2
ii  fwupd-amd64-signed [fwupd-signed]  1.5.7+4
ii  python3                            3.9.2-3
pn  secureboot-db                      <none>
ii  udisks2                            2.9.2-2+deb11u1

Versions of packages fwupd suggests:
ii  gir1.2-fwupd-2.0  1.5.7-4

-- no debconf information

---

From: Klaus Kudielka <[email-masked]>
Date: Sun, 10 Apr 2022 14:49:55 +0200

For the records:

Up to and including systemd 250.3 (testing), the service worked (with 
libnss-systemd installed).
After upgrade to systemd 250.4, yet another failure mechanism seems to 
have popped up:

"DynamicUser is denied access to dbus-daemon after a recent lockup bugfix"
https://github.com/systemd/systemd/issues/22737

End result:
systemd[1]: Failed to start Refresh fwupd metadata and update motd.

Regards, Klaus