Subject: Bug#948288: gnome-shell reproducibly crashes on boot, and the boot process gets stuck

From: "Md Ayquassar" <[email-masked]>
Date: Mon, 6 Jan 2020 19:38:27 +0300

Package: gnome-shell
Version: 3.30.2-11~deb10u1
Severity: important

Upon boot, my laptop gets stuck at "Started GNOME Display Manager." (see the
attachment). Examining dmesg reveals:

[44.363854] gnome-shell[808]: segfault at 0 ip 00000000 sp bff2c2ac error 4 in
gnome-shell[443000+2000]

[44.363866] Code: Bad RIP value

...

[791.460436] gnome-shell[886]: segfault at 0 ip 00000000 sp bf8135ec error 4 in
gnome-shell[426000+2000]
[791.460448] Code: Bad RIP value
I use buster 10, uname -a returns

Linux T42-LAPTOP 4.19.0-6-686 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) i686
GNU/Linux

The installation is FRESH; xorg has been favored by the installer automatically.

Using Ctrl+Alt+F2 followed by Ctrl+Alt+F1 makes the boot continue without other
observable ill effects.
How do I get rid of this manual intervention? If I ship this to a client, the
client says "system unusable".

---

From: "Md Ayquassar" <[email-masked]>
Date: Mon, 6 Jan 2020 20:02:41 +0300

Below you find is the dmesg output.

[ 0.000000] Linux version 4.19.0-6-686 ([email-masked]) (gcc
version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11)
[ 0.000000] Disabled fast string operations
[ 0.000000] x86/fpu: x87 FPU will use FXSAVE
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009efff] usable
[ 0.000000] BIOS-e820: [mem 0x000000000009f000-0x000000000009ffff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000000d2000-0x00000000000d3fff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000000dc000-0x00000000000fffff] reserved
[ 0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000007ff5ffff] usable
[ 0.000000] BIOS-e820: [mem 0x000000007ff60000-0x000000007ff76fff] ACPI data
[ 0.000000] BIOS-e820: [mem 0x000000007ff77000-0x000000007ff78fff] ACPI NVS
[ 0.000000] BIOS-e820: [mem 0x000000007ff80000-0x000000007fffffff] reserved
[ 0.000000] BIOS-e820: [mem 0x00000000ff800000-0x00000000ffffffff] reserved
[ 0.000000] Notice: NX (Execute Disable) protection missing in CPU!
[ 0.000000] SMBIOS 2.3 present.
[ 0.000000] DMI: IBM 2373ZJD/2373ZJD, BIOS 1RETDRWW (3.23 ) 06/18/2007
[ 0.000000] tsc: Fast TSC calibration failed
[ 0.000000] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[ 0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[ 0.000000] last_pfn = 0x7ff60 max_arch_pfn = 0x100000
[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-CFFFF write-protect
[ 0.000000] D0000-DBFFF uncachable
[ 0.000000] DC000-DFFFF write-back
[ 0.000000] E0000-FFFFF write-protect
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 000000000 mask F80000000 write-back
[ 0.000000] 1 base 07FF80000 mask FFFF80000 uncachable
[ 0.000000] 2 disabled
[ 0.000000] 3 disabled
[ 0.000000] 4 disabled
[ 0.000000] 5 disabled
[ 0.000000] 6 disabled
[ 0.000000] 7 disabled
[ 0.000000] x86/PAT: PAT not supported by CPU.
[ 0.000000] x86/PAT: Configuration [0-7]: WB WT UC- UC WB WT UC- UC
[ 0.000000] initial memory mapped: [mem 0x00000000-0x1fffffff]
[ 0.000000] BRK [0x1faf7000, 0x1faf7fff] PGTABLE
[ 0.000000] RAMDISK: [mem 0x32681000-0x35337fff]
[ 0.000000] ACPI: Early table checksum verification disabled
[ 0.000000] ACPI: RSDP 0x00000000000F6D70 000024 (v02 IBM )
[ 0.000000] ACPI: XSDT 0x000000007FF6A672 00004C (v01 IBM TP-1R 00003230 LTP
00000000)
[ 0.000000] ACPI: FACP 0x000000007FF6A700 0000F4 (v03 IBM TP-1R 00003230 IBM
00000001)
[ 0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Gpe0Block:
64/32 (20180810/tbfadt-569)
[ 0.000000] ACPI BIOS Warning (bug): Optional FADT field Gpe1Block has valid
Address but zero Length: 0x000000000000102C/0x0 (20180810/tbfadt-624)
[ 0.000000] ACPI: DSDT 0x000000007FF6A8E7 00C530 (v01 IBM TP-1R 00003230 MSFT
0100000E)
[ 0.000000] ACPI: FACS 0x000000007FF78000 000040
[ 0.000000] ACPI: FACS 0x000000007FF78000 000040
[ 0.000000] ACPI: SSDT 0x000000007FF6A8B4 000033 (v01 IBM TP-1R 00003230 MSFT
0100000E)
[ 0.000000] ACPI: ECDT 0x000000007FF76E17 000052 (v01 IBM TP-1R 00003230 IBM
00000001)
[ 0.000000] ACPI: TCPA 0x000000007FF76E69 000032 (v01 IBM TP-1R 00003230 PTL
00000001)
[ 0.000000] ACPI: BOOT 0x000000007FF76FD8 000028 (v01 IBM TP-1R 00003230 LTP
00000001)
[ 0.000000] 1171MB HIGHMEM available.
[ 0.000000] 875MB LOWMEM available.
[ 0.000000] mapped low ram: 0 - 36bfe000
[ 0.000000] low ram: 0 - 36bfe000
[ 0.000000] BRK [0x1faf8000, 0x1faf8fff] PGTABLE
[ 0.000000] Zone ranges:
[ 0.000000] DMA [mem 0x0000000000001000-0x0000000000ffffff]
[ 0.000000] Normal [mem 0x0000000001000000-0x0000000036bfdfff]
[ 0.000000] HighMem [mem 0x0000000036bfe000-0x000000007ff5ffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000001000-0x000000000009efff]
[ 0.000000] node 0: [mem 0x0000000000100000-0x000000007ff5ffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000001000-0x000000007ff5ffff]
[ 0.000000] On node 0 totalpages: 524030
[ 0.000000] DMA zone: 40 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 3998 pages, LIFO batch:0
[ 0.000000] Normal zone: 2150 pages used for memmap
[ 0.000000] Normal zone: 220158 pages, LIFO batch:63
[ 0.000000] HighMem zone: 299874 pages, LIFO batch:63
[ 0.000000] Using APIC driver default
[ 0.000000] ACPI: PM-Timer IO Port: 0x1008
[ 0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[ 0.000000] APIC: disable apic facility
[ 0.000000] APIC: switched to apic NOOP
[ 0.000000] smpboot: Allowing 1 CPUs, 0 hotplug CPUs
[ 0.000000] PM: Registered nosave memory: [mem 0x00000000-0x00000fff]
[ 0.000000] PM: Registered nosave memory: [mem 0x0009f000-0x0009ffff]
[ 0.000000] PM: Registered nosave memory: [mem 0x000a0000-0x000d1fff]
[ 0.000000] PM: Registered nosave memory: [mem 0x000d2000-0x000d3fff]
[ 0.000000] PM: Registered nosave memory: [mem 0x000d4000-0x000dbfff]
[ 0.000000] PM: Registered nosave memory: [mem 0x000dc000-0x000fffff]
[ 0.000000] [mem 0x80000000-0xff7fffff] available for PCI devices
[ 0.000000] Booting paravirtualized kernel on bare hardware
[ 0.000000] clocksource: refined-jiffies: mask: 0xffffffff max_cycles:
0xffffffff, max_idle_ns: 7645519600211568 ns
[ 0.000000] random: get_random_bytes called from start_kernel+0x81/0x474 with
crng_init=0
[ 0.000000] setup_percpu: NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:1
nr_node_ids:1
[ 0.000000] percpu: Embedded 29 pages/cpu s87884 r0 d30900 u118784
[ 0.000000] pcpu-alloc: s87884 r0 d30900 u118784 alloc=29*4096
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 521840
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-6-686
root=UUID=c2e7e76d-6ee0-4705-9f83-ed1310bcbced ro quiet
[ 0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[ 0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[ 0.000000] BRK [0x1faf9000, 0x1faf9fff] PGTABLE
[ 0.000000] Initializing CPU#0
[ 0.000000] Initializing HighMem for node 0 (00036bfe:0007ff60)
[ 0.000000] Initializing Movable for node 0 (00000000:00000000)
[ 0.000000] Memory: 2017632K/2096120K available (6630K kernel code, 639K rwdata,
2076K rodata, 840K init, 436K bss, 78488K reserved, 0K cma-reserved, 1199496K
highmem)
[ 0.000000] virtual kernel memory layout:
fixmap : 0xffd35000 - 0xfffff000 (2856 kB)
cpu_entry : 0xff400000 - 0xff8e1000 (4996 kB)
pkmap : 0xfec00000 - 0xff000000 (4096 kB)
vmalloc : 0xf73fe000 - 0xfebfe000 ( 120 MB)
lowmem : 0xc0000000 - 0xf6bfe000 ( 875 MB)
.init : 0xdf931000 - 0xdfa03000 ( 840 kB)
.data : 0xdf679aa0 - 0xdf921e80 (2720 kB)
.text : 0xdf000000 - 0xdf679aa0 (6630 kB)
[ 0.000000] Checking if this processor honours the WP bit even in supervisor
mode...Ok.
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] ftrace: allocating 29304 entries in 58 pages
[ 0.000000] rcu: Hierarchical RCU implementation.
[ 0.000000] rcu: RCU restricting CPUs from NR_CPUS=32 to nr_cpu_ids=1.
[ 0.000000] rcu: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=1
[ 0.000000] NR_IRQS: 2304, nr_irqs: 32, preallocated irqs: 16
[ 0.000000] CPU 0 irqstacks, hard=(ptrval) soft=(ptrval)
[ 0.000000] Console: colour VGA+ 80x25
[ 0.000000] console [tty0] enabled
[ 0.000000] ACPI: Core revision 20180810
[ 0.000000] ACPI: setting ELCR to 0200 (from 0800)
[ 0.000000] APIC: Keep in PIC mode(8259)
[ 0.004000] tsc: PIT calibration matches PMTIMER. 1 loops
[ 0.004000] tsc: Detected 1698.555 MHz processor
[ 0.000017] clocksource: tsc-early: mask: 0xffffffffffffffff max_cycles:
0x187bd23b5d8, max_idle_ns: 440795207547 ns
[ 0.000031] Calibrating delay loop (skipped), value calculated using timer
frequency.. 3397.11 BogoMIPS (lpj=6794220)
[ 0.000036] pid_max: default: 32768 minimum: 301
[ 0.000103] Security Framework initialized
[ 0.000106] Yama: disabled by default; enable with sysctl kernel.yama.*
[ 0.000152] AppArmor: AppArmor initialized
[ 0.000185] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000195] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000600] Disabled fast string operations
[ 0.000636] Last level iTLB entries: 4KB 128, 2MB 0, 4MB 2
[ 0.000638] Last level dTLB entries: 4KB 128, 2MB 0, 4MB 8, 1GB 0
[ 0.000641] Spectre V1 : Mitigation: usercopy/swapgs barriers and __user pointer
sanitization
[ 0.000645] Spectre V2 : Mitigation: Full generic retpoline
[ 0.000647] Spectre V2 : Spectre v2 / SpectreRSB mitigation: Filling RSB on
context switch
[ 0.000648] Speculative Store Bypass: Vulnerable
[ 0.000649] L1TF: Kernel not compiled for PAE. No mitigation for L1TF
[ 0.000673] MDS: Vulnerable: Clear CPU buffers attempted, no microcode
[ 0.007731] Freeing SMP alternatives memory: 24K
[ 0.016156] smpboot: weird, boot CPU (#0) not listed by the BIOS
[ 0.016158] smpboot: SMP disabled
[ 0.016354] Performance Events:
[ 0.016358] no APIC, boot with the "lapic" boot parameter to force-enable it.
[ 0.016359] no hardware sampling interrupt available.
[ 0.016361] p6 PMU driver.
[ 0.016363] ... version: 0
[ 0.016365] ... bit width: 32
[ 0.016366] ... generic registers: 2
[ 0.016367] ... value mask: 00000000ffffffff
[ 0.016368] ... max period: 000000007fffffff
[ 0.016369] ... fixed-purpose events: 0
[ 0.016370] ... event mask: 0000000000000003
[ 0.016443] rcu: Hierarchical SRCU implementation.
[ 0.017288] NMI watchdog: Enabled. Permanently consumes one hw-PMU counter.
[ 0.017338] smp: Bringing up secondary CPUs ...
[ 0.017340] smp: Brought up 1 node, 1 CPU
[ 0.017342] smpboot: Max logical packages: 1
[ 0.017344] smpboot: Total of 1 processors activated (3397.11 BogoMIPS)
[ 0.017648] devtmpfs: initialized
[ 0.018013] PM: Registering ACPI NVS region [mem 0x7ff77000-0x7ff78fff] (8192
bytes)
[ 0.018097] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff,
max_idle_ns: 7645041785100000 ns
[ 0.018103] futex hash table entries: 256 (order: 2, 16384 bytes)
[ 0.018188] pinctrl core: initialized pinctrl subsystem
[ 0.018531] NET: Registered protocol family 16
[ 0.018710] audit: initializing netlink subsys (disabled)
[ 0.018932] cpuidle: using governor ladder
[ 0.018934] cpuidle: using governor menu
[ 0.018989] Simple Boot Flag at 0x35 set to 0x1
[ 0.018999] clocksource: pit: mask: 0xffffffff max_cycles: 0xffffffff,
max_idle_ns: 1601818034827 ns
[ 0.019025] ACPI: bus type PCI registered
[ 0.019027] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[ 0.019764] PCI: PCI BIOS revision 2.10 entry at 0xfd8d6, last bus=8
[ 0.019766] PCI: Using configuration type 1 for base access
[ 0.021278] audit: type=2000 audit(1578329135.020:1): state=initialized
audit_enabled=0 res=1
[ 0.021429] HugeTLB registered 4.00 MiB page size, pre-allocated 0 pages
[ 0.021860] ACPI: Added _OSI(Module Device)
[ 0.021862] ACPI: Added _OSI(Processor Device)
[ 0.021864] ACPI: Added _OSI(3.0 _SCP Extensions)
[ 0.021865] ACPI: Added _OSI(Processor Aggregator Device)
[ 0.021867] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.021869] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.021876] ACPI: EC: EC started
[ 0.021877] ACPI: EC: interrupt blocked
[ 0.021904] ACPI: \: Used as first EC
[ 0.021907] ACPI: \: GPE=0x1c, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[ 0.021909] ACPI: \: Used as boot ECDT EC to handle transactions
[ 0.034421] ACPI: 2 ACPI AML tables successfully acquired and loaded
[ 0.044486] ACPI: Interpreter enabled
[ 0.044517] ACPI: (supports S0 S3 S4 S5)
[ 0.044519] ACPI: Using PIC for interrupt routing
[ 0.044542] PCI: Ignoring host bridge windows from ACPI; if necessary, use
"pci=use_crs" and report a bug
[ 0.044799] ACPI: Enabled 1 GPEs in block 00 to 1F
[ 0.049409] ACPI: Power Resource [PUBS] (on)
[ 0.052997] acpi PNP0C0A:01: ACPI dock station (docks/bays count: 1)
[ 0.054101] acpi LNXDOCK:00: ACPI dock station (docks/bays count: 2)
[ 0.055059] acpi LNXIOBAY:00: ACPI dock station (docks/bays count: 3)
[ 0.060885] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11)
[ 0.061050] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 *11)
[ 0.061212] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 *11)
[ 0.061374] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 *11)
[ 0.061497] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10 11) *0,
disabled.
[ 0.061620] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 11) *0,
disabled.
[ 0.061743] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 9 10 11) *0,
disabled.
[ 0.061906] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10 *11)
[ 0.062466] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[ 0.062472] acpi PNP0A03:00: _OSC: OS supports [ASPM ClockPM Segments MSI]
[ 0.062479] acpi PNP0A03:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[ 0.062485] acpi PNP0A03:00: fail to add MMCONFIG information, can't access
extended PCI configuration space under this bridge.
[ 0.062513] acpi PNP0A03:00: host bridge window [io 0x0cf8-0x0cff] (ignored)
[ 0.062516] acpi PNP0A03:00: host bridge window [io 0x0000-0x0cf7 window]
(ignored)
[ 0.062518] acpi PNP0A03:00: host bridge window [io 0x0d00-0xffff window]
(ignored)
[ 0.062520] acpi PNP0A03:00: host bridge window [mem 0x000a0000-0x000bffff
window] (ignored)
[ 0.062523] acpi PNP0A03:00: host bridge window [mem 0x000d4000-0x000d7fff
window] (ignored)
[ 0.062525] acpi PNP0A03:00: host bridge window [mem 0x000d8000-0x000dbfff
window] (ignored)
[ 0.062527] acpi PNP0A03:00: host bridge window [mem 0x80000000-0xfebfffff
window] (ignored)
[ 0.062529] PCI: root bus 00: using default resources
[ 0.062705] PCI host bridge to bus 0000:00
[ 0.062708] pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
[ 0.062711] pci_bus 0000:00: root bus resource [mem 0x00000000-0xffffffff]
[ 0.062714] pci_bus 0000:00: root bus resource [bus 00-ff]
[ 0.062728] pci 0000:00:00.0: [8086:3340] type 00 class 0x060000
[ 0.062741] pci 0000:00:00.0: reg 0x10: [mem 0xd0000000-0xdfffffff pref]
[ 0.062869] pci 0000:00:01.0: [8086:3341] type 01 class 0x060400
[ 0.063009] pci 0000:00:1d.0: [8086:24c2] type 00 class 0x0c0300
[ 0.063057] pci 0000:00:1d.0: reg 0x20: [io 0x1800-0x181f]
[ 0.063180] pci 0000:00:1d.1: [8086:24c4] type 00 class 0x0c0300
[ 0.063228] pci 0000:00:1d.1: reg 0x20: [io 0x1820-0x183f]
[ 0.063348] pci 0000:00:1d.2: [8086:24c7] type 00 class 0x0c0300
[ 0.063395] pci 0000:00:1d.2: reg 0x20: [io 0x1840-0x185f]
[ 0.063529] pci 0000:00:1d.7: [8086:24cd] type 00 class 0x0c0320
[ 0.063554] pci 0000:00:1d.7: reg 0x10: [mem 0xc0000000-0xc00003ff]
[ 0.063645] pci 0000:00:1d.7: PME# supported from D0 D3hot D3cold
[ 0.063749] pci 0000:00:1e.0: [8086:2448] type 01 class 0x060400
[ 0.063885] pci 0000:00:1f.0: [8086:24cc] type 00 class 0x060100
[ 0.063956] pci 0000:00:1f.0: quirk: [io 0x1000-0x107f] claimed by ICH4
ACPI/GPIO/TCO
[ 0.063961] pci 0000:00:1f.0: quirk: [io 0x1180-0x11bf] claimed by ICH4 GPIO
[ 0.064068] pci 0000:00:1f.1: [8086:24ca] type 00 class 0x01018a
[ 0.064086] pci 0000:00:1f.1: reg 0x10: [io 0x0000-0x0007]
[ 0.064096] pci 0000:00:1f.1: reg 0x14: [io 0x0000-0x0003]
[ 0.064106] pci 0000:00:1f.1: reg 0x18: [io 0x0000-0x0007]
[ 0.064115] pci 0000:00:1f.1: reg 0x1c: [io 0x0000-0x0003]
[ 0.064125] pci 0000:00:1f.1: reg 0x20: [io 0x1860-0x186f]
[ 0.064134] pci 0000:00:1f.1: reg 0x24: [mem 0x00000000-0x000003ff]
[ 0.064147] pci 0000:00:1f.1: legacy IDE quirk: reg 0x10: [io 0x01f0-0x01f7]
[ 0.064150] pci 0000:00:1f.1: legacy IDE quirk: reg 0x14: [io 0x03f6]
[ 0.064152] pci 0000:00:1f.1: legacy IDE quirk: reg 0x18: [io 0x0170-0x0177]
[ 0.064154] pci 0000:00:1f.1: legacy IDE quirk: reg 0x1c: [io 0x0376]
[ 0.064254] pci 0000:00:1f.3: [8086:24c3] type 00 class 0x0c0500
[ 0.064302] pci 0000:00:1f.3: reg 0x20: [io 0x1880-0x189f]
[ 0.064407] pci 0000:00:1f.5: [8086:24c5] type 00 class 0x040100
[ 0.064425] pci 0000:00:1f.5: reg 0x10: [io 0x1c00-0x1cff]
[ 0.064434] pci 0000:00:1f.5: reg 0x14: [io 0x18c0-0x18ff]
[ 0.064443] pci 0000:00:1f.5: reg 0x18: [mem 0xc0000c00-0xc0000dff]
[ 0.064452] pci 0000:00:1f.5: reg 0x1c: [mem 0xc0000800-0xc00008ff]
[ 0.064499] pci 0000:00:1f.5: PME# supported from D0 D3hot D3cold
[ 0.064591] pci 0000:00:1f.6: [8086:24c6] type 00 class 0x070300
[ 0.064610] pci 0000:00:1f.6: reg 0x10: [io 0x2400-0x24ff]
[ 0.064619] pci 0000:00:1f.6: reg 0x14: [io 0x2000-0x207f]
[ 0.064679] pci 0000:00:1f.6: PME# supported from D0 D3hot D3cold
[ 0.064777] pci_bus 0000:01: extended config space not accessible
[ 0.064832] pci 0000:01:00.0: [1002:4c57] type 00 class 0x030000
[ 0.064845] pci 0000:01:00.0: reg 0x10: [mem 0xe0000000-0xe7ffffff pref]
[ 0.064852] pci 0000:01:00.0: reg 0x14: [io 0x3000-0x30ff]
[ 0.064860] pci 0000:01:00.0: reg 0x18: [mem 0xc0100000-0xc010ffff]
[ 0.064882] pci 0000:01:00.0: reg 0x30: [mem 0x00000000-0x0001ffff pref]
[ 0.064912] pci 0000:01:00.0: supports D1 D2
[ 0.064998] pci 0000:00:01.0: PCI bridge to [bus 01]
[ 0.065002] pci 0000:00:01.0: bridge window [io 0x3000-0x3fff]
[ 0.065005] pci 0000:00:01.0: bridge window [mem 0xc0100000-0xc01fffff]
[ 0.065009] pci 0000:00:01.0: bridge window [mem 0xe0000000-0xe7ffffff pref]
[ 0.065024] pci_bus 0000:02: extended config space not accessible
[ 0.065119] acpiphp: Slot [1-1] registered
[ 0.065134] pci 0000:02:00.0: [104c:ac46] type 02 class 0x060700
[ 0.065151] pci 0000:02:00.0: reg 0x10: [mem 0xb0000000-0xb0000fff]
[ 0.065183] pci 0000:02:00.0: supports D1 D2
[ 0.065185] pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[ 0.065275] pci 0000:02:00.1: [104c:ac46] type 02 class 0x060700
[ 0.065292] pci 0000:02:00.1: reg 0x10: [mem 0xb1000000-0xb1000fff]
[ 0.065324] pci 0000:02:00.1: supports D1 D2
[ 0.065326] pci 0000:02:00.1: PME# supported from D0 D1 D2 D3hot D3cold
[ 0.065423] pci 0000:02:01.0: [8086:101e] type 00 class 0x020000
[ 0.065440] pci 0000:02:01.0: reg 0x10: [mem 0xc0240000-0xc025ffff]
[ 0.065449] pci 0000:02:01.0: reg 0x14: [mem 0xc0200000-0xc020ffff]
[ 0.065459] pci 0000:02:01.0: reg 0x18: [io 0x8000-0x803f]
[ 0.065489] pci 0000:02:01.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[ 0.065521] pci 0000:02:01.0: PME# supported from D0 D3hot D3cold
[ 0.065601] pci 0000:02:02.0: [168c:1014] type 00 class 0x020000
[ 0.065618] pci 0000:02:02.0: reg 0x10: [mem 0xc0210000-0xc021ffff]
[ 0.065778] pci 0000:00:1e.0: PCI bridge to [bus 02-08] (subtractive decode)
[ 0.065782] pci 0000:00:1e.0: bridge window [io 0x4000-0x8fff]
[ 0.065787] pci 0000:00:1e.0: bridge window [mem 0xc0200000-0xcfffffff]
[ 0.065791] pci 0000:00:1e.0: bridge window [mem 0xe8000000-0xefffffff pref]
[ 0.065794] pci 0000:00:1e.0: bridge window [io 0x0000-0xffff] (subtractive
decode)
[ 0.065796] pci 0000:00:1e.0: bridge window [mem 0x00000000-0xffffffff]
(subtractive decode)
[ 0.065825] pci_bus 0000:03: extended config space not accessible
[ 0.065859] pci_bus 0000:03: busn_res: [bus 03-08] end is updated to 06
[ 0.065879] pci_bus 0000:07: extended config space not accessible
[ 0.065906] pci_bus 0000:07: busn_res: [bus 07-08] end is updated to 07
[ 0.065919] pci_bus 0000:00: on NUMA node 0
[ 0.067706] ACPI: EC: interrupt unblocked
[ 0.067715] ACPI: EC: event unblocked
[ 0.067722] ACPI: \_SB_.PCI0.LPC_.EC__: GPE=0x1c, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[ 0.067724] ACPI: \_SB_.PCI0.LPC_.EC__: Used as boot DSDT EC to handle
transactions and events
[ 0.067852] pci 0000:01:00.0: vgaarb: setting as boot VGA device
[ 0.067855] pci 0000:01:00.0: vgaarb: VGA device added:
decodes=io+mem,owns=io+mem,locks=none
[ 0.067858] pci 0000:01:00.0: vgaarb: bridge control possible
[ 0.067859] vgaarb: loaded
[ 0.067967] EDAC MC: Ver: 3.0.0
[ 0.068225] PCI: Using ACPI for IRQ routing
[ 0.068362] PCI: pci_cache_line_size set to 64 bytes
[ 0.068411] e820: reserve RAM buffer [mem 0x0009f000-0x0009ffff]
[ 0.068413] e820: reserve RAM buffer [mem 0x7ff60000-0x7fffffff]
[ 0.071574] clocksource: Switched to clocksource tsc-early
[ 0.092172] VFS: Disk quotas dquot_6.6.0
[ 0.092209] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.092448] AppArmor: AppArmor Filesystem Enabled
[ 0.092518] pnp: PnP ACPI init
[ 0.093346] system 00:00: [mem 0x00000000-0x0009ffff] could not be reserved
[ 0.093350] system 00:00: [mem 0x000c0000-0x000c3fff] could not be reserved
[ 0.093353] system 00:00: [mem 0x000c4000-0x000c7fff] could not be reserved
[ 0.093356] system 00:00: [mem 0x000c8000-0x000cbfff] could not be reserved
[ 0.093358] system 00:00: [mem 0x000cc000-0x000cffff] could not be reserved
[ 0.093361] system 00:00: [mem 0x000d0000-0x000d3fff] could not be reserved
[ 0.093364] system 00:00: [mem 0x000dc000-0x000dffff] could not be reserved
[ 0.093367] system 00:00: [mem 0x000e0000-0x000e3fff] could not be reserved
[ 0.093369] system 00:00: [mem 0x000e4000-0x000e7fff] could not be reserved
[ 0.093372] system 00:00: [mem 0x000e8000-0x000ebfff] could not be reserved
[ 0.093375] system 00:00: [mem 0x000ec000-0x000effff] could not be reserved
[ 0.093378] system 00:00: [mem 0x000f0000-0x000fffff] could not be reserved
[ 0.093380] system 00:00: [mem 0x00100000-0x7fffffff] could not be reserved
[ 0.093383] system 00:00: [mem 0xfec00000-0xffffffff] could not be reserved
[ 0.093395] system 00:00: Plug and Play ACPI device, IDs PNP0c01 (active)
[ 0.093622] system 00:01: [io 0x1000-0x107f] has been reserved
[ 0.093626] system 00:01: [io 0x1180-0x11bf] has been reserved
[ 0.093628] system 00:01: [io 0x15e0-0x15ef] has been reserved
[ 0.093631] system 00:01: [io 0x1600-0x162f] has been reserved
[ 0.093634] system 00:01: [io 0x1632-0x167f] has been reserved
[ 0.093637] system 00:01: [io 0x1630-0x1631] has been reserved
[ 0.093644] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
[ 0.093699] pnp 00:02: Plug and Play ACPI device, IDs PNP0b00 (active)
[ 0.093745] pnp 00:03: Plug and Play ACPI device, IDs PNP0303 (active)
[ 0.093801] pnp 00:04: Plug and Play ACPI device, IDs IBM0057 PNP0f13 (active)
[ 0.093937] pnp 00:05: Plug and Play ACPI device, IDs PNP0501 (disabled)
[ 0.094149] pnp 00:06: Plug and Play ACPI device, IDs PNP0400 (active)
[ 0.094294] pnp 00:07: [dma 3]
[ 0.094391] pnp 00:07: Plug and Play ACPI device, IDs IBM0071 PNP0511 (active)
[ 0.095100] pnp: PnP ACPI: found 8 devices
[ 0.095104] PnPBIOS: Disabled by ACPI PNP
[ 0.132353] clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff,
max_idle_ns: 2085701024 ns
[ 0.132404] pci 0000:00:1f.1: BAR 5: assigned [mem 0x80000000-0x800003ff]
[ 0.132413] pci 0000:01:00.0: BAR 6: assigned [mem 0xc0120000-0xc013ffff pref]
[ 0.132416] pci 0000:00:01.0: PCI bridge to [bus 01]
[ 0.132419] pci 0000:00:01.0: bridge window [io 0x3000-0x3fff]
[ 0.132423] pci 0000:00:01.0: bridge window [mem 0xc0100000-0xc01fffff]
[ 0.132426] pci 0000:00:01.0: bridge window [mem 0xe0000000-0xe7ffffff pref]
[ 0.132438] pci 0000:02:00.0: BAR 15: assigned [mem 0xe8000000-0xebffffff pref]
[ 0.132441] pci 0000:02:00.0: BAR 16: assigned [mem 0xc4000000-0xc7ffffff]
[ 0.132444] pci 0000:02:00.1: BAR 15: assigned [mem 0xec000000-0xefffffff pref]
[ 0.132447] pci 0000:02:00.1: BAR 16: assigned [mem 0xc8000000-0xcbffffff]
[ 0.132450] pci 0000:02:01.0: BAR 6: assigned [mem 0xc0220000-0xc022ffff pref]
[ 0.132453] pci 0000:02:00.0: BAR 13: assigned [io 0x4000-0x40ff]
[ 0.132455] pci 0000:02:00.0: BAR 14: assigned [io 0x4400-0x44ff]
[ 0.132458] pci 0000:02:00.1: BAR 13: assigned [io 0x4800-0x48ff]
[ 0.132460] pci 0000:02:00.1: BAR 14: assigned [io 0x4c00-0x4cff]
[ 0.132464] pci 0000:02:00.0: CardBus bridge to [bus 03-06]
[ 0.132466] pci 0000:02:00.0: bridge window [io 0x4000-0x40ff]
[ 0.132470] pci 0000:02:00.0: bridge window [io 0x4400-0x44ff]
[ 0.132475] pci 0000:02:00.0: bridge window [mem 0xe8000000-0xebffffff pref]
[ 0.132479] pci 0000:02:00.0: bridge window [mem 0xc4000000-0xc7ffffff]
[ 0.132491] pci 0000:02:00.1: CardBus bridge to [bus 07]
[ 0.132494] pci 0000:02:00.1: bridge window [io 0x4800-0x48ff]
[ 0.132498] pci 0000:02:00.1: bridge window [io 0x4c00-0x4cff]
[ 0.132502] pci 0000:02:00.1: bridge window [mem 0xec000000-0xefffffff pref]
[ 0.132506] pci 0000:02:00.1: bridge window [mem 0xc8000000-0xcbffffff]
[ 0.132510] pci 0000:00:1e.0: PCI bridge to [bus 02-08]
[ 0.132514] pci 0000:00:1e.0: bridge window [io 0x4000-0x8fff]
[ 0.132519] pci 0000:00:1e.0: bridge window [mem 0xc0200000-0xcfffffff]
[ 0.132523] pci 0000:00:1e.0: bridge window [mem 0xe8000000-0xefffffff pref]
[ 0.132531] pci_bus 0000:00: resource 4 [io 0x0000-0xffff]
[ 0.132533] pci_bus 0000:00: resource 5 [mem 0x00000000-0xffffffff]
[ 0.132536] pci_bus 0000:01: resource 0 [io 0x3000-0x3fff]
[ 0.132538] pci_bus 0000:01: resource 1 [mem 0xc0100000-0xc01fffff]
[ 0.132540] pci_bus 0000:01: resource 2 [mem 0xe0000000-0xe7ffffff pref]
[ 0.132543] pci_bus 0000:02: resource 0 [io 0x4000-0x8fff]
[ 0.132545] pci_bus 0000:02: resource 1 [mem 0xc0200000-0xcfffffff]
[ 0.132547] pci_bus 0000:02: resource 2 [mem 0xe8000000-0xefffffff pref]
[ 0.132550] pci_bus 0000:02: resource 4 [io 0x0000-0xffff]
[ 0.132552] pci_bus 0000:02: resource 5 [mem 0x00000000-0xffffffff]
[ 0.132554] pci_bus 0000:03: resource 0 [io 0x4000-0x40ff]
[ 0.132557] pci_bus 0000:03: resource 1 [io 0x4400-0x44ff]
[ 0.132559] pci_bus 0000:03: resource 2 [mem 0xe8000000-0xebffffff pref]
[ 0.132561] pci_bus 0000:03: resource 3 [mem 0xc4000000-0xc7ffffff]
[ 0.132564] pci_bus 0000:07: resource 0 [io 0x4800-0x48ff]
[ 0.132566] pci_bus 0000:07: resource 1 [io 0x4c00-0x4cff]
[ 0.132568] pci_bus 0000:07: resource 2 [mem 0xec000000-0xefffffff pref]
[ 0.132570] pci_bus 0000:07: resource 3 [mem 0xc8000000-0xcbffffff]
[ 0.132718] NET: Registered protocol family 2
[ 0.133004] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144
bytes)
[ 0.133016] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.133054] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.133124] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.133219] UDP hash table entries: 512 (order: 2, 16384 bytes)
[ 0.133239] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[ 0.133322] NET: Registered protocol family 1
[ 0.133332] NET: Registered protocol family 44
[ 0.133797] PCI Interrupt Link [LNKA] enabled at IRQ 11
[ 0.133799] PCI: setting IRQ 11 as level-triggered
[ 0.134201] PCI Interrupt Link [LNKD] enabled at IRQ 11
[ 0.134446] PCI Interrupt Link [LNKC] enabled at IRQ 11
[ 0.134690] PCI Interrupt Link [LNKH] enabled at IRQ 11
[ 0.134771] pci 0000:01:00.0: Video device with shadowed ROM at [mem
0x000c0000-0x000dffff]
[ 0.134790] PCI: CLS 32 bytes, default 64
[ 0.134875] Unpacking initramfs...
[ 0.984557] random: fast init done
[ 1.592751] Freeing initrd memory: 45788K
[ 1.594064] Initialise system trusted keyrings
[ 1.594092] Key type blacklist registered
[ 1.594202] workingset: timestamp_bits=14 max_order=19 bucket_order=5
[ 1.596938] zbud: loaded
[ 2.620090] tsc: Refined TSC clocksource calibration: 1698.557 MHz
[ 2.620099] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x187bd4226b5,
max_idle_ns: 440795278921 ns
[ 2.620119] clocksource: Switched to clocksource tsc
[ 2.957811] Key type asymmetric registered
[ 2.957815] Asymmetric key parser 'x509' registered
[ 2.957842] bounce: pool size: 64 pages
[ 2.957877] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 249)
[ 2.957949] io scheduler noop registered
[ 2.957950] io scheduler deadline registered
[ 2.958064] io scheduler cfq registered (default)
[ 2.958066] io scheduler mq-deadline registered
[ 2.958498] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[ 2.958525] intel_idle: does not run on family 6 model 13
[ 2.959028] tsc: Marking TSC unstable due to TSC halts in idle
[ 2.959333] isapnp: Scanning for PnP cards...
[ 2.964831] clocksource: Switched to clocksource acpi_pm
[ 3.312270] isapnp: No Plug & Play device found
[ 3.312411] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 3.312518] serial 00:05: [io 0x03f8-0x03ff]
[ 3.312564] serial 00:05: [irq 4]
[ 3.312925] serial 00:05: activated
[ 3.312992] 00:05: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 921600) is a NS16550A
[ 3.313235] serial8250: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 921600) is a
NS16550A
[ 3.313807] PCI Interrupt Link [LNKB] enabled at IRQ 11
[ 3.313993] Linux agpgart interface v0.103
[ 3.314160] agpgart-intel 0000:00:00.0: Intel 855PM Chipset
[ 3.328228] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
[ 3.328457] i8042: PNP: PS/2 Controller [PNP0303:KBD,PNP0f13:MOU] at 0x60,0x64
irq 1,12
[ 3.335292] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 3.335301] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 3.335484] mousedev: PS/2 mouse device common for all mice
[ 3.335549] rtc_cmos 00:02: RTC can wake from S4
[ 3.335690] rtc_cmos 00:02: registered as rtc0
[ 3.335718] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram
[ 3.335758] ledtrig-cpu: registered to indicate activity on CPUs
[ 3.336699] NET: Registered protocol family 10
[ 3.341043] input: AT Translated Set 2 keyboard as
/devices/platform/i8042/serio0/input/input0
[ 3.350001] Segment Routing with IPv6
[ 3.350042] mip6: Mobile IPv6
[ 3.350046] NET: Registered protocol family 17
[ 3.350095] mpls_gso: MPLS GSO support
[ 3.350238] mce: Using 5 MCE banks
[ 3.350305] microcode: sig=0x6d6, pf=0x20, revision=0x18
[ 3.350365] microcode: Microcode Update Driver: v2.2.
[ 3.350369] Using IPI No-Shortcut mode
[ 3.350556] registered taskstats version 1
[ 3.350557] Loading compiled-in X.509 certificates
[ 3.661389] Loaded X.509 cert 'Debian Secure Boot CA:
6ccece7e4c6c0d1f6149f3dd27dfcc5cbb419ea1'
[ 3.661418] Loaded X.509 cert 'Debian Secure Boot Signer: 00a7468def'
[ 3.661442] zswap: loaded using pool lzo/zbud
[ 3.661503] AppArmor: AppArmor sha1 policy hashing enabled
[ 3.661879] rtc_cmos 00:02: setting system clock to 2020-01-06 16:45:38 UTC
(1578329138)
[ 3.661926] Unstable clock detected, switching default tracing clock to "global"
If you want to keep using the local clock, then add:
"trace_clock=local"
on the kernel command line
[ 3.663872] Freeing unused kernel image memory: 840K
[ 3.672132] Write protecting the kernel text: 6632k
[ 3.672194] Write protecting the kernel read-only data: 2080k
[ 3.672196] Run /init as init process
[ 3.823745] ACPI: Video Device [VID] (multi-head: yes rom: no post: no)
[ 3.823987] input: Video Bus as
/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:02/LNXVIDEO:00/input/input2
[ 3.825460] input: Lid Switch as
/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3
[ 3.825620] ACPI: Lid Switch [LID]
[ 3.825704] input: Sleep Button as
/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input4
[ 3.825719] ACPI: Sleep Button [SLPB]
[ 3.825808] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input5
[ 3.825822] ACPI: Power Button [PWRF]
[ 3.903783] i801_smbus 0000:00:1f.3: SMBus using polling
[ 3.919566] thermal LNXTHERM:00: registered as thermal_zone0
[ 3.919570] ACPI: Thermal Zone [THM0] (53 C)
[ 3.977394] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[ 3.977397] e1000: Copyright (c) 1999-2006 Intel Corporation.
[ 3.986659] ACPI: bus type USB registered
[ 3.986696] usbcore: registered new interface driver usbfs
[ 3.986716] usbcore: registered new interface driver hub
[ 4.009908] usbcore: registered new device driver usb
[ 4.024377] SCSI subsystem initialized
[ 4.092310] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.098003] ehci-pci: EHCI PCI platform driver
[ 4.098139] ehci-pci 0000:00:1d.7: EHCI Host Controller
[ 4.098150] ehci-pci 0000:00:1d.7: new USB bus registered, assigned bus number 1
[ 4.098170] ehci-pci 0000:00:1d.7: debug port 1
[ 4.102074] ehci-pci 0000:00:1d.7: cache line size of 32 is not supported
[ 4.109726] uhci_hcd: USB Universal Host Controller Interface driver
[ 4.130628] ehci-pci 0000:00:1d.7: irq 11, io mem 0xc0000000
[ 4.144106] ehci-pci 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[ 4.144214] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002,
bcdDevice= 4.19
[ 4.144217] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 4.144219] usb usb1: Product: EHCI Host Controller
[ 4.144221] usb usb1: Manufacturer: Linux 4.19.0-6-686 ehci_hcd
[ 4.144223] usb usb1: SerialNumber: 0000:00:1d.7
[ 4.144460] hub 1-0:1.0: USB hub found
[ 4.144474] hub 1-0:1.0: 6 ports detected
[ 4.145270] uhci_hcd 0000:00:1d.0: UHCI Host Controller
[ 4.145280] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[ 4.145288] uhci_hcd 0000:00:1d.0: detected 2 ports
[ 4.145313] uhci_hcd 0000:00:1d.0: irq 11, io base 0x00001800
[ 4.145402] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001,
bcdDevice= 4.19
[ 4.145405] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 4.145407] usb usb2: Product: UHCI Host Controller
[ 4.145409] usb usb2: Manufacturer: Linux 4.19.0-6-686 uhci_hcd
[ 4.145411] usb usb2: SerialNumber: 0000:00:1d.0
[ 4.145592] hub 2-0:1.0: USB hub found
[ 4.145605] hub 2-0:1.0: 2 ports detected
[ 4.145847] uhci_hcd 0000:00:1d.1: UHCI Host Controller
[ 4.145854] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
[ 4.145860] uhci_hcd 0000:00:1d.1: detected 2 ports
[ 4.145877] uhci_hcd 0000:00:1d.1: irq 11, io base 0x00001820
[ 4.145956] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001,
bcdDevice= 4.19
[ 4.145958] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 4.145960] usb usb3: Product: UHCI Host Controller
[ 4.145962] usb usb3: Manufacturer: Linux 4.19.0-6-686 uhci_hcd
[ 4.145964] usb usb3: SerialNumber: 0000:00:1d.1
[ 4.146122] hub 3-0:1.0: USB hub found
[ 4.146133] hub 3-0:1.0: 2 ports detected
[ 4.146336] uhci_hcd 0000:00:1d.2: UHCI Host Controller
[ 4.146342] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
[ 4.146349] uhci_hcd 0000:00:1d.2: detected 2 ports
[ 4.146375] uhci_hcd 0000:00:1d.2: irq 11, io base 0x00001840
[ 4.146457] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001,
bcdDevice= 4.19
[ 4.146459] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 4.146461] usb usb4: Product: UHCI Host Controller
[ 4.146463] usb usb4: Manufacturer: Linux 4.19.0-6-686 uhci_hcd
[ 4.146465] usb usb4: SerialNumber: 0000:00:1d.2
[ 4.146623] hub 4-0:1.0: USB hub found
[ 4.146634] hub 4-0:1.0: 2 ports detected
[ 4.170550] libata version 3.00 loaded.
[ 4.185938] ata_piix 0000:00:1f.1: version 2.13
[ 4.185950] ata_piix 0000:00:1f.1: enabling device (0005 -> 0007)
[ 4.194397] scsi host0: ata_piix
[ 4.201919] scsi host1: ata_piix
[ 4.202014] ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x1860 irq 14
[ 4.202016] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x1868 irq 15
[ 4.367971] ata1.00: ATA-6: HTS541040G9AT00, MB2IA60A, max UDMA/100
[ 4.367976] ata1.00: 78140160 sectors, multi 16: LBA
[ 4.368521] ata2.00: ATAPI: DVD/CDRW UJDA775, CB03, max UDMA/33
[ 4.373699] scsi 0:0:0:0: Direct-Access ATA HTS541040G9AT00 A60A PQ: 0 ANSI: 5
[ 4.379294] scsi 1:0:0:0: CD-ROM MATSHITA DVD/CDRW UJDA775 CB03 PQ: 0 ANSI: 5
[ 4.399330] [drm] radeon kernel modesetting enabled.
[ 4.401323] [drm] initializing kernel modesetting (RV200 0x1002:0x4C57
0x1014:0x0530 0x00).
[ 4.401782] agpgart-intel 0000:00:00.0: AGP 2.0 bridge
[ 4.401793] agpgart-intel 0000:00:00.0: putting AGP V2 device into 1x mode
[ 4.401822] radeon 0000:01:00.0: putting AGP V2 device into 1x mode
[ 4.401841] radeon 0000:01:00.0: GTT: 256M 0xD0000000 - 0xDFFFFFFF
[ 4.401849] radeon 0000:01:00.0: VRAM: 128M 0x00000000E0000000 -
0x00000000E7FFFFFF (32M used)
[ 4.402259] [drm] Detected VRAM RAM=128M, BAR=128M
[ 4.402262] [drm] RAM width 64bits DDR
[ 4.402390] [TTM] Zone kernel: Available graphics memory: 432394 kiB
[ 4.402391] [TTM] Zone highmem: Available graphics memory: 1032142 kiB
[ 4.402392] [TTM] Initializing pool allocator
[ 4.402429] [drm] radeon: 32M of VRAM memory ready
[ 4.402431] [drm] radeon: 256M of GTT memory ready.
[ 4.402470] [drm] radeon: power management initialized
[ 4.403242] radeon 0000:01:00.0: WB disabled
[ 4.403253] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr
0x00000000d0000000 and cpu addr 0x(ptrval)
[ 4.403256] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 4.403257] [drm] Driver supports precise vblank timestamp query.
[ 4.403273] [drm] radeon: irq initialized.
[ 4.403292] [drm] Loading R100 Microcode
[ 4.403380] radeon 0000:01:00.0: firmware: direct-loading firmware
radeon/R100_cp.bin
[ 4.403602] [drm] radeon: ring at 0x00000000D0001000
[ 4.403626] [drm] ring test succeeded in 1 usecs
[ 4.403837] [drm] ib test succeeded in 0 usecs
[ 4.405211] [drm] Panel ID String: 1024x768
[ 4.405213] [drm] Panel Size 1024x768
[ 4.405485] [drm] No TV DAC info found in BIOS
[ 4.405750] [drm] Radeon Display Connectors
[ 4.405752] [drm] Connector 0:
[ 4.405753] [drm] VGA-1
[ 4.405755] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[ 4.405756] [drm] Encoders:
[ 4.405757] [drm] CRT1: INTERNAL_DAC1
[ 4.405759] [drm] Connector 1:
[ 4.405759] [drm] DVI-D-1
[ 4.405760] [drm] HPD1
[ 4.405762] [drm] DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
[ 4.405763] [drm] Encoders:
[ 4.405764] [drm] DFP1: INTERNAL_TMDS1
[ 4.405765] [drm] Connector 2:
[ 4.405766] [drm] LVDS-1
[ 4.405766] [drm] Encoders:
[ 4.405767] [drm] LCD1: INTERNAL_LVDS
[ 4.405768] [drm] Connector 3:
[ 4.405769] [drm] SVIDEO-1
[ 4.405770] [drm] Encoders:
[ 4.405771] [drm] TV1: INTERNAL_DAC2
[ 4.451446] sd 0:0:0:0: [sda] 78140160 512-byte logical blocks: (40.0 GB/37.3
GiB)
[ 4.451461] sd 0:0:0:0: [sda] Write Protect is off
[ 4.451464] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 4.451482] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't
support DPO or FUA
[ 4.489867] sda: sda1 sda2 < sda5 >
[ 4.490811] sd 0:0:0:0: [sda] Attached SCSI disk
[ 4.507209] [drm] fb mappable at 0xE0040000
[ 4.507211] [drm] vram apper at 0xE0000000
[ 4.507212] [drm] size 1572864
[ 4.507213] [drm] fb depth is 16
[ 4.507214] [drm] pitch is 2048
[ 4.512052] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda
tray
[ 4.512055] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 4.512702] sr 1:0:0:0: Attached scsi CD-ROM sr0
[ 4.529327] fbcon: radeondrmfb (fb0) is primary device
[ 4.614485] Console: switching to colour frame buffer device 128x48
[ 4.623754] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[ 4.623857] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
[ 4.650383] e1000 0000:02:01.0 eth0: (PCI:33MHz:32-bit) 00:15:58:0a:57:2f
[ 4.650390] e1000 0000:02:01.0 eth0: Intel(R) PRO/1000 Network Connection
[ 4.652463] e1000 0000:02:01.0 enp2s1: renamed from eth0
[ 4.848203] psmouse serio1: synaptics: Touchpad model: 1, fw: 5.9, id: 0x2c6ab1,
caps: 0x884793/0x0/0x0/0x0, board id: 0, fw id: 4797594
[ 4.848211] psmouse serio1: synaptics: serio: Synaptics pass-through port at
isa0060/serio1/input0
[ 4.889417] input: SynPS/2 Synaptics TouchPad as
/devices/platform/i8042/serio1/input/input6
[ 5.413414] PM: Image not found (code -22)
[ 5.571340] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons:
3/3
[ 5.591864] cryptd: max_cpu_qlen set to 1000
[ 5.688579] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts:
(null)
[ 5.829774] input: TPPS/2 IBM TrackPoint as
/devices/platform/i8042/serio1/serio2/input/input7
[ 7.995829] systemd[1]: Inserted module 'autofs4'
[ 8.026104] random: crng init done
[ 8.247535] systemd[1]: systemd 241 running in system mode. (+PAM +AUDIT +SELINUX
+IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ
+LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 8.247700] systemd[1]: Detected architecture x86.
[ 8.270233] systemd[1]: Set hostname to <T42-LAPTOP>.
[ 8.280313] systemd[1]: Failed to bump fs.file-max, ignoring: Invalid argument
[ 10.362795] systemd[1]: Started Forward Password Requests to Wall Directory
Watch.
[ 10.362944] systemd[1]: Listening on initctl Compatibility Named Pipe.
[ 10.363225] systemd[1]: Listening on Journal Audit Socket.
[ 10.363533] systemd[1]: Set up automount Arbitrary Executable File Formats File
System Automount Point.
[ 10.363695] systemd[1]: Listening on Journal Socket (/dev/log).
[ 10.364659] systemd[1]: Created slice User and Session Slice.
[ 11.034050] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 11.572246] systemd-journald[180]: Received request to flush runtime journal
from PID 1
[ 11.590557] lp: driver loaded but no devices found
[ 11.640388] ppdev: user-space parallel port driver
[ 11.714987] parport_pc 00:06: reported by Plug and Play ACPI
[ 11.715072] parport0: PC-style at 0x3bc, irq 7 [PCSPP,TRISTATE]
[ 11.812206] lp0: using parport0 (interrupt-driven).
[ 14.693692] intel_rng: FWH not detected
[ 14.831445] ACPI: AC Adapter [AC] (on-line)
[ 14.885678] battery: ACPI: Battery Slot [BAT0] (battery present)
[ 14.905511] Non-volatile memory driver v1.3
[ 15.163310] iTCO_vendor_support: vendor-support=0
[ 15.167093] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
[ 15.167151] iTCO_wdt: Found a ICH4-M TCO device (Version=1, TCOBASE=0x1060)
[ 15.180159] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[ 15.181031] thinkpad_acpi: ThinkPad ACPI Extras v0.26
[ 15.181033] thinkpad_acpi: http://ibm-acpi.sf.net/
[ 15.181034] thinkpad_acpi: ThinkPad BIOS 1RETDRWW (3.23 ), EC 1RHT71WW-3.04
[ 15.181035] thinkpad_acpi: IBM ThinkPad T42, model 2373ZJD
[ 15.196094] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is blocked
[ 15.200742] thinkpad_acpi: Console audio control enabled, mode: monitor (read
only)
[ 15.204319] thinkpad_acpi: battery 1 registered (start 0, stop 0)
[ 15.204325] battery: new extension: ThinkPad Battery Extension
[ 15.204399] input: ThinkPad Extra Buttons as
/devices/platform/thinkpad_acpi/input/input8
[ 15.224475] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 15.224529] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 15.256849] snd_intel8x0m 0000:00:1f.6: MC'97 1 converters and GPIO not ready
(0xff00)
[ 15.367501] yenta_cardbus 0000:02:00.0: CardBus bridge found [1014:0552]
[ 15.367518] yenta_cardbus 0000:02:00.0: Using INTVAL to route CSC interrupts to
PCI
[ 15.367520] yenta_cardbus 0000:02:00.0: Routing CardBus interrupts to PCI
[ 15.367525] yenta_cardbus 0000:02:00.0: TI: mfunc 0x01d21b22, devctl 0x64
[ 15.390464] input: PC Speaker as /devices/platform/pcspkr/input/input9
[ 15.608615] yenta_cardbus 0000:02:00.0: ISA IRQ mask 0x0478, PCI irq 11
[ 15.608621] yenta_cardbus 0000:02:00.0: Socket status: 30000086
[ 15.608630] yenta_cardbus 0000:02:00.0: pcmcia: parent PCI bridge window: [io
0x4000-0x8fff]
[ 15.608634] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x4000-0x8fff:
[ 15.609383] excluding 0x4000-0x40ff 0x4400-0x44ff 0x4800-0x48ff 0x4c00-0x4cff
0x8000-0x803f
[ 15.635439] yenta_cardbus 0000:02:00.0: pcmcia: parent PCI bridge window: [mem
0xc0200000-0xcfffffff]
[ 15.635443] pcmcia_socket pcmcia_socket0: cs: memory probe
0xc0200000-0xcfffffff:
[ 15.635445] excluding 0xc0200000-0xc09fffff 0xc3a00000-0xcc1fffff
0xcfa00000-0xd01fffff
[ 15.635470] yenta_cardbus 0000:02:00.0: pcmcia: parent PCI bridge window: [mem
0xe8000000-0xefffffff pref]
[ 15.635472] pcmcia_socket pcmcia_socket0: cs: memory probe
0xe8000000-0xefffffff:
[ 15.635479] excluding 0xe8000000-0xefffffff
[ 15.643861] yenta_cardbus 0000:02:00.1: CardBus bridge found [1014:0552]
[ 15.643879] yenta_cardbus 0000:02:00.1: Using INTVAL to route CSC interrupts to
PCI
[ 15.643881] yenta_cardbus 0000:02:00.1: Routing CardBus interrupts to PCI
[ 15.643885] yenta_cardbus 0000:02:00.1: TI: mfunc 0x01d21b22, devctl 0x64
[ 15.884621] yenta_cardbus 0000:02:00.1: ISA IRQ mask 0x0478, PCI irq 11
[ 15.884630] yenta_cardbus 0000:02:00.1: Socket status: 30000086
[ 15.884646] yenta_cardbus 0000:02:00.1: pcmcia: parent PCI bridge window: [io
0x4000-0x8fff]
[ 15.884654] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x4000-0x8fff:
[ 15.885549] excluding 0x4000-0x40ff 0x4400-0x44ff 0x4800-0x48ff 0x4c00-0x4cff
0x8000-0x803f
[ 15.906421] yenta_cardbus 0000:02:00.1: pcmcia: parent PCI bridge window: [mem
0xc0200000-0xcfffffff]
[ 15.906424] pcmcia_socket pcmcia_socket1: cs: memory probe
0xc0200000-0xcfffffff:
[ 15.906426] excluding 0xc0200000-0xc09fffff 0xc3a00000-0xcc1fffff
0xcfa00000-0xd01fffff
[ 15.906451] yenta_cardbus 0000:02:00.1: pcmcia: parent PCI bridge window: [mem
0xe8000000-0xefffffff pref]
[ 15.906454] pcmcia_socket pcmcia_socket1: cs: memory probe
0xe8000000-0xefffffff:
[ 15.906461] excluding 0xe8000000-0xefffffff
[ 16.188105] snd_intel8x0 0000:00:1f.5: intel8x0_measure_ac97_clock: measured
59252 usecs (2854 samples)
[ 16.188114] snd_intel8x0 0000:00:1f.5: clocking to 48000
[ 17.263776] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x100-0x3af:
[ 17.265959] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af:
[ 17.266655] excluding 0x170-0x177 0x1f0-0x1f7 0x2f8-0x2ff 0x370-0x377
[ 17.267234] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff:
[ 17.267496] excluding 0x3f0-0x3ff 0x4d0-0x4d7
[ 17.267796] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff:
[ 17.271186] excluding 0x170-0x177 0x1f0-0x1f7 0x2f8-0x2ff 0x370-0x377
[ 17.271661] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x3e0-0x4ff:
[ 17.272391] clean
[ 17.272418] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xc00-0xcf7:
[ 17.272785] clean
[ 17.272813] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff:
[ 17.272819] excluding 0xc0000-0xd3fff 0xdc000-0xfffff
[ 17.272850] pcmcia_socket pcmcia_socket0: cs: memory probe
0xa0000000-0xa0ffffff:
[ 17.272866] clean
[ 17.272887] pcmcia_socket pcmcia_socket0: cs: memory probe
0x60000000-0x60ffffff:
[ 17.272898] excluding 0x60000000-0x60ffffff
[ 17.272922] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xa00-0xaff:
[ 17.273301] clean
[ 17.273370] excluding 0x3f0-0x3ff 0x4d0-0x4d7
[ 17.273581] pcmcia_socket pcmcia_socket1: cs: IO port probe 0x820-0x8ff:
[ 17.273912] clean
[ 17.273934] pcmcia_socket pcmcia_socket1: cs: IO port probe 0xc00-0xcf7:
[ 17.274301] clean
[ 17.274326] pcmcia_socket pcmcia_socket1: cs: memory probe 0x0c0000-0x0fffff:
[ 17.274331] excluding 0xc0000-0xd3fff 0xdc000-0xfffff
[ 17.274361] pcmcia_socket pcmcia_socket1: cs: memory probe
0xa0000000-0xa0ffffff:
[ 17.274377] clean
[ 17.274398] pcmcia_socket pcmcia_socket1: cs: memory probe
0x60000000-0x60ffffff:
[ 17.274409] excluding 0x60000000-0x60ffffff
[ 17.274432] pcmcia_socket pcmcia_socket1: cs: IO port probe 0xa00-0xaff:
[ 17.274810] clean
[ 18.080373] ath5k 0000:02:02.0: registered as 'phy0'
[ 18.390396] ath: EEPROM regdomain: 0x61
[ 18.390399] ath: EEPROM indicates we should expect a direct regpair map
[ 18.390404] ath: Country alpha2 being used: 00
[ 18.390405] ath: Regpair used: 0x61
[ 18.594311] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 18.595050] ath5k: phy0: Atheros AR5212 chip found (MAC: 0x56, PHY: 0x41)
[ 18.595054] ath5k: phy0: RF5111 5GHz radio found (0x17)
[ 18.595057] ath5k: phy0: RF2111 2GHz radio found (0x23)
[ 18.630628] ath5k 0000:02:02.0 wlp2s2: renamed from wlan0
[ 18.699244] Adding 2095100k swap on /dev/sda5. Priority:-2 extents:1
across:2095100k FS
[ 31.373378] IPv6: ADDRCONF(NETDEV_UP): enp2s1: link is not ready
[ 31.374094] IPv6: ADDRCONF(NETDEV_UP): enp2s1: link is not ready
[ 31.380129] e1000: enp2s1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control:
RX/TX
[ 31.380296] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s1: link becomes ready
[ 31.413253] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 31.428622] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 31.446369] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 32.447158] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 43.510369] gnome-shell[810]: segfault at 0 ip 00000000 sp bfc9ba8c error 4 in
gnome-shell[49d000+2000]
[ 43.510382] Code: Bad RIP value.
[ 51.075945] gnome-shell[838]: segfault at 0 ip 00000000 sp bf924fec error 4 in
gnome-shell[4ed000+2000]
[ 51.075957] Code: Bad RIP value.

---

From: Bernhard Übelacker <[email-masked]>
Date: Tue, 7 Jan 2020 14:24:44 +0100

Hello Md Ayquassar,
I am not involved in packaging gnome-shell, but may have
some pointers to gather some more informations for the
maintainer.

You could try to install the package systemd-coredump.
That way the output of 'journalctl --no-pager' should give
some information where the crash happened below
the line "segfault at".

Additionally that output would be a lot more helpful if
you could install the debug symbol package gnome-shell-dbgsym
before the process crashes.
This package comes from a separate repository
described in following link:

    https://wiki.debian.org/HowToGetABacktrace#Installing_the_debugging_symbols

Kind regards,
Bernhard

---

From: "Md Ayquassar" <[email-masked]>
Date: Fri, 17 Jan 2020 02:11:25 +0300

Bernhard, I'm afraid it gets nasty, but, anyway, I installed the package
gnome-shell-dbgsym, systemd-coredump, then rebooted, then stored the outputs of
'dmesg', 'journalctl --no-pager', 'coredumpctl info', and the file
/var/lib/systemd/coredump/core.gnome-shell.117.070a923b6f474dada3645eeb67710dc3.899.1579215018000000.lz4.They
are all attached to this e-mail.

---

From: Bernhard Übelacker <[email-masked]>
Date: Fri, 17 Jan 2020 23:45:18 +0100

Hello Md Ayquassar,
could you please additionally run following and attach the
output to this bug:

   reportbug --template gnome-shell

I am asking because trying to open the coredump shows
following warning inside a minimal uptodate Buster/stable
VM, which could point to a incompatibility of some used
shared libraries:

   warning: Could not load shared library symbols for 120 libraries, e.g. /lib/i386-linux-gnu/libgio-2.0.so.0.

Kind regards,
Bernhard

---

From: "Md Ayquassar" <[email-masked]>
Date: Thu, 30 Jan 2020 22:08:16 +0300

Below you find the output of
guest@T42-LAPTOP:~$ reportbug --template gnome-shell 1>>/tmp/reportbug_output.log
2>&1

copied and pasted from the file repotbug_output.log:

Warning: no reportbug configuration found. Proceeding in novice mode.
Detected character set: UTF-8
Please change your locale if this is incorrect.Using 'guest
<[email-masked]>' as your from address.
Getting status for gnome-shell...
Will send report to Debian (per lsb_release).
Maintainer for gnome-shell is 'Debian GNOME Maintainers
<[email-masked]>'.
Looking up dependencies of gnome-shell...
Getting status for related package gnome-session...
Looking up 'depends' of related package gnome-session...
Looking up 'suggests' of related package gnome-session...
Getting status for related package gnome-settings-daemon...
Looking up 'depends' of related package gnome-settings-daemon...
Looking up 'recommends' of related package gnome-settings-daemon...
Getting status for related package libgjs0g...
Looking up 'depends' of related package libgjs0g...
Getting status for related package libmutter-3-0...
Looking up 'depends' of related package libmutter-3-0...
Looking up status of additional packages...
Getting changed configuration files...Rewriting subject to 'gnome-shell: none'
Saving a backup of the report at
/tmp/reportbug-gnome-shell-backup-20200130-3154-vovyhuqk
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: guest <[email-masked]>
To: Debian Bug Tracking System <[email-masked]>
Subject: gnome-shell: nonePackage: gnome-shell
Version: 3.30.2-11~deb10u1
Severity: wishlistDear Maintainer,*** Reporter, please consider answering these
questions, where appropriate **** What led up to the situation?
* What exactly did you do (or not do) that was effective (or
ineffective)?
* What was the outcome of this action?
* What outcome did you expect instead?*** End of the template - remove these
template lines ***
-- System Information:
Debian Release: 10.2
APT prefers stable-updates
APT policy: (500, 'stable-updates'), (500, 'stable-debug'), (500,
'proposed-updates-debug'), (500, 'stable')
Architecture: i386 (i686)Kernel: Linux 4.19.0-6-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8),
LANGUAGE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)Versions of packages gnome-shell depends
on:
ii dconf-gsettings-backend [gsettings-backend] 0.30.1-2
ii evolution-data-server 3.30.5-1
ii gir1.2-accountsservice-1.0 0.6.45-2
ii gir1.2-atspi-2.0 2.30.0-7
ii gir1.2-freedesktop 1.58.3-2
ii gir1.2-gcr-3 3.28.1-1
ii gir1.2-gdesktopenums-3.0 3.28.1-1
ii gir1.2-gdm-1.0 3.30.2-3
ii gir1.2-geoclue-2.0 2.5.2-1
ii gir1.2-glib-2.0 1.58.3-2
ii gir1.2-gnomebluetooth-1.0 3.28.2-4~deb10u1
ii gir1.2-gnomedesktop-3.0 3.30.2.1-2
ii gir1.2-gtk-3.0 3.24.5-1
ii gir1.2-gweather-3.0 3.28.2-2
ii gir1.2-ibus-1.0 1.5.19-4+deb10u1
ii gir1.2-mutter-3 3.30.2-9~deb10u1
ii gir1.2-nm-1.0 1.14.6-2+deb10u1
ii gir1.2-nma-1.0 1.8.20-1.1
ii gir1.2-pango-1.0 1.42.4-7~deb10u1
ii gir1.2-polkit-1.0 0.105-25
ii gir1.2-rsvg-2.0 2.44.10-2.1
ii gir1.2-soup-2.4 2.64.2-2
ii gir1.2-upowerglib-1.0 0.99.10-1
ii gjs 1.54.3-1
ii gnome-backgrounds 3.30.0-1
ii gnome-settings-daemon 3.30.2-3
ii gnome-shell-common 3.30.2-11~deb10u1
ii gsettings-desktop-schemas 3.28.1-1
ii libatk-bridge2.0-0 2.30.0-5
ii libatk1.0-0 2.30.0-2
ii libc6 2.28-10
ii libcairo2 1.16.0-4
ii libcanberra-gtk3-0 0.30-7
ii libcanberra0 0.30-7
ii libcroco3 0.6.12-3
ii libecal-1.2-19 3.30.5-1
ii libedataserver-1.2-23 3.30.5-1
ii libgcr-base-3-1 3.28.1-1
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libgirepository-1.0-1 1.58.3-2
ii libgjs0g 1.54.3-1
ii libglib2.0-0 2.58.3-2+deb10u2
ii libglib2.0-bin 2.58.3-2+deb10u2
ii libgstreamer1.0-0 1.14.4-1
ii libgtk-3-0 3.24.5-1
ii libical3 3.0.4-3
ii libjson-glib-1.0-0 1.4.4-2
ii libmutter-3-0 3.30.2-9~deb10u1
ii libnm0 1.14.6-2+deb10u1
ii libpango-1.0-0 1.42.4-7~deb10u1
ii libpangocairo-1.0-0 1.42.4-7~deb10u1
ii libpolkit-agent-1-0 0.105-25
ii libpolkit-gobject-1-0 0.105-25
ii libpulse-mainloop-glib0 12.2-4+deb10u1
ii libpulse0 12.2-4+deb10u1
ii libsecret-1-0 0.18.7-1
ii libstartup-notification0 0.12-6
ii libsystemd0 241-7~deb10u2
ii libx11-6 2:1.6.7-1
ii libxfixes3 1:5.0.3-1
ii mutter 3.30.2-9~deb10u1
ii python3 3.7.3-1Versions of packages gnome-shell recommends:
ii bolt 0.7-2
ii chrome-gnome-shell 10.1-5
ii gdm3 3.30.2-3
ii gkbd-capplet 3.26.1-1
ii gnome-control-center 1:3.30.3-2~deb10u1
ii gnome-user-docs 3.30.2-1
ii iio-sensor-proxy 2.4-2
ii switcheroo-control 1.2-2
ii unzip 6.0-23+deb10u1Versions of packages gnome-shell suggests:
pn gir1.2-telepathyglib-0.12 <none>
pn gir1.2-telepathylogger-0.2 <none>Versions of packages gnome-session depends
on:
ii gnome-session-bin 3.30.1-2
ii gnome-session-common 3.30.1-2
ii gnome-settings-daemon 3.30.2-3Versions of packages gnome-session suggests:
ii desktop-base 10.0.2
ii gnome-keyring 3.28.2-5Versions of packages gnome-settings-daemon depends on:
ii gnome-settings-daemon-common 3.30.2-3
ii gsettings-desktop-schemas 3.28.1-1
ii libasound2 1.1.8-1
ii libc6 2.28-10
ii libcairo2 1.16.0-4
ii libcanberra-gtk3-0 0.30-7
ii libcanberra0 0.30-7
ii libcolord2 1.4.3-4
ii libcups2 2.2.10-6+deb10u1
ii libfontconfig1 2.13.1-2
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libgeoclue-2-0 2.5.2-1
ii libgeocode-glib0 3.26.1-1
ii libglib2.0-0 2.58.3-2+deb10u2
ii libgnome-desktop-3-17 3.30.2.1-2
ii libgtk-3-0 3.24.5-1
ii libgudev-1.0-0 232-2
ii libgweather-3-15 3.28.2-2
ii liblcms2-2 2.9-3
ii libnm0 1.14.6-2+deb10u1
ii libnotify4 0.7.7-4
ii libnspr4 2:4.20-1
ii libnss3 2:3.42.1-1+deb10u2
ii libpam-systemd 241-7~deb10u2
ii libpango-1.0-0 1.42.4-7~deb10u1
ii libpangocairo-1.0-0 1.42.4-7~deb10u1
ii libpolkit-gobject-1-0 0.105-25
ii libpulse-mainloop-glib0 12.2-4+deb10u1
ii libpulse0 12.2-4+deb10u1
ii libupower-glib3 0.99.10-1
ii libwacom2 0.32-1
ii libwayland-client0 1.16.0-1
ii libx11-6 2:1.6.7-1
ii libxext6 2:1.3.3-1+b2
ii libxi6 2:1.7.9-1Versions of packages gnome-settings-daemon recommends:
ii iio-sensor-proxy 2.4-2
ii pulseaudio 12.2-4+deb10u1Versions of packages libgjs0g depends on:
ii gir1.2-glib-2.0 1.58.3-2
ii gir1.2-gtk-3.0 3.24.5-1
ii libatk1.0-0 2.30.0-2
ii libc6 2.28-10
ii libcairo-gobject2 1.16.0-4
ii libcairo2 1.16.0-4
ii libffi6 3.2.1-9
ii libgcc1 1:8.3.0-6
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libgirepository-1.0-1 1.58.3-2
ii libglib2.0-0 2.58.3-2+deb10u2
ii libgtk-3-0 3.24.5-1
ii libmozjs-60-0 60.2.3-3
ii libpango-1.0-0 1.42.4-7~deb10u1
ii libpangocairo-1.0-0 1.42.4-7~deb10u1
ii libreadline7 7.0-5
ii libstdc++6 8.3.0-6
ii libx11-6 2:1.6.7-1
ii libxext6 2:1.3.3-1+b2Versions of packages libmutter-3-0 depends on:
ii gsettings-desktop-schemas 3.28.1-1
ii libatk1.0-0 2.30.0-2
ii libc6 2.28-10
ii libcairo-gobject2 1.16.0-4
ii libcairo2 1.16.0-4
ii libcanberra-gtk3-0 0.30-7
ii libcanberra0 0.30-7
ii libdrm2 2.4.97-1
ii libegl1 1.1.0-1
ii libfontconfig1 2.13.1-2
ii libgbm1 18.3.6-2
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libgirepository-1.0-1 1.58.3-2
ii libgl1 1.1.0-1
ii libglib2.0-0 2.58.3-2+deb10u2
ii libgnome-desktop-3-17 3.30.2.1-2
ii libgtk-3-0 3.24.5-1
ii libgudev-1.0-0 232-2
ii libice6 2:1.0.9-2
ii libinput10 1.12.6-2
ii libjson-glib-1.0-0 1.4.4-2
ii libpango-1.0-0 1.42.4-7~deb10u1
ii libpangocairo-1.0-0 1.42.4-7~deb10u1
ii libpangoft2-1.0-0 1.42.4-7~deb10u1
ii libpipewire-0.2-1 0.2.5-1
ii libsm6 2:1.2.3-1
ii libstartup-notification0 0.12-6
ii libsystemd0 241-7~deb10u2
ii libudev1 241-7~deb10u2
ii libwacom2 0.32-1
ii libwayland-server0 1.16.0-1
ii libx11-6 2:1.6.7-1
ii libx11-xcb1 2:1.6.7-1
ii libxcb-randr0 1.13.1-2
ii libxcb-res0 1.13.1-2
ii libxcb1 1.13.1-2
ii libxcomposite1 1:0.4.4-2
ii libxcursor1 1:1.1.15-2
ii libxdamage1 1:1.1.4-3+b3
ii libxext6 2:1.3.3-1+b2
ii libxfixes3 1:5.0.3-1
ii libxi6 2:1.7.9-1
ii libxinerama1 2:1.1.4-2
ii libxkbcommon-x11-0 0.8.2-1
ii libxkbcommon0 0.8.2-1
ii libxkbfile1 1:1.0.9-2+b11
ii libxrandr2 2:1.5.1-1
ii libxrender1 1:0.9.10-1
ii libxtst6 2:1.2.3-1
ii mutter-common 3.30.2-9~deb10u1Versions of packages gnome-shell is related to:
ii libegl-mesa0 [libegl-vendor] 18.3.6-2
ii libgl1-mesa-dri 18.3.6-2
ii libglx-mesa0 [libglx-vendor] 18.3.6-2-- no debconf information

---

From: "Md Ayquassar" <[email-masked]>
Date: Thu, 30 Jan 2020 22:18:32 +0300

Dear Bernhard:

In the attachment you find the output again and file generated, namely,
/tmp/reportbug-gnome-shell-backup-20200130-3154-vovyhuqk. (I think the
attachments might be easier to view due to line breaks at proper places.)

Best regards,
Md Ayquassar

---

From: Bernhard Übelacker <[email-masked]>
Date: Fri, 31 Jan 2020 02:09:14 +0100

Hello Md Ayquassar,
sorry, I did not recognize that you
seem to have a usrmerge'd system.

Then I get following backtraces from your
core dump, with and without debug symbols.

It looks like a function pointer gets called
unconditionally, while containing NULL.
Seems to be graphics driver related.

Kind regards,
Bernhard

https://sources.debian.org/src/mesa/18.3.6-2/src/egl/drivers/dri2/egl_dri2.c/#L1017

(gdb) bt
#0  0x00000000 in ?? ()
#1  0xaf7d2c74 in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
#2  0xaf7d755e in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
#3  0xade2d004 in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
#4  0xade2d812 in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
#5  0xade9232f in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
#6  0xaf7d29ba in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
#7  0xaf7c061c in eglMakeCurrent () from /lib/i386-linux-gnu/libEGL_mesa.so.0
#8  0xb4cd8b58 in ?? () from /lib/i386-linux-gnu/libEGL.so.1
#9  0xb674a1bd in _cogl_winsys_egl_make_current () from /usr/lib/i386-linux-gnu/mutter/libmutter-cogl-3.so
#10 0xb6d8f1f6 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
#11 0xb6ceaca4 in meta_renderer_rebuild_views () from /lib/i386-linux-gnu/libmutter-3.so.0
#12 0xb6d920fa in meta_stage_native_rebuild_views () from /lib/i386-linux-gnu/libmutter-3.so.0
#13 0xb6d83ba7 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
#14 0xb6ccf11a in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
#15 0xb6ccff40 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
#16 0xb6d83f98 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
#17 0xb6cd053a in meta_clutter_init () from /lib/i386-linux-gnu/libmutter-3.so.0
#18 0xb6d20323 in meta_init () from /lib/i386-linux-gnu/libmutter-3.so.0
#19 0x004ad53d in ?? ()
#20 0xb6aa2b41 in __libc_start_main (main=0x4ad430, argc=1, argv=0xbff2c2a4, init=0x4adfa0, fini=0x4ae000, rtld_fini=0xb7f97520 <_dl_fini>, stack_end=0xbff2c29c) at ../csu/libc-start.c:308
#21 0x004ad8d1 in ?? ()
(gdb) 

Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00000000 in ?? ()
[Current thread is 1 (Thread 0xb1f2eb80 (LWP 899))]
(gdb) set width 0
(gdb) set pagination off
(gdb) bt
#0  0x00000000 in ?? ()
#1  0xaf7d2c74 in dri2_egl_surface_alloc_local_buffer (dri2_surf=0x1b8e9f0, att=9, format=32) at ../src/egl/drivers/dri2/egl_dri2.c:1017
#2  0xaf7d755e in dri2_drm_get_buffers_with_format (driDrawable=0x1b73580, width=0x1b73598, height=0x1b7359c, attachments=0xbff2bb04, count=2, out_count=0xbff2baf8, loaderPrivate=0x1b8e9f0) at ../src/egl/drivers/dri2/platform_drm.c:344
#3  0xade2d004 in radeon_update_renderbuffers (context=0x19e7d60, drawable=0x1b73580, front_only=0 '\000') at ../src/mesa/drivers/dri/radeon/radeon_common_context.c:421
#4  0xade2d812 in radeonMakeCurrent (driContextPriv=0x19e7d60, driDrawPriv=0x1b73580, driReadPriv=0x1b73580) at ../src/mesa/drivers/dri/radeon/radeon_common_context.c:616
#5  0xade9232f in driBindContext (pcp=0x19e7d60, pdp=0x1b73580, prp=0x1b73580) at ../src/mesa/drivers/dri/common/dri_util.c:579
#6  0xaf7d29ba in dri2_make_current (drv=0x19e5120, disp=0x19e49c0, dsurf=0x1b8e9f0, rsurf=0x1b8e9f0, ctx=<optimized out>) at ../src/egl/drivers/dri2/egl_dri2.c:1516
#7  0xaf7c061c in eglMakeCurrent (dpy=0x19e49c0, draw=0x1b8e9f0, read=0x1b8e9f0, ctx=0x19fe5c0) at ../src/egl/main/eglapi.c:860
#8  0xb4cd8b58 in InternalMakeCurrentVendor (dpy=0x19e3dd0, draw=draw@entry=0x1b8e9f0, read=0x1b8e9f0, read@entry=0x19c3310, context=0x19fe5c0, apiState=0x19fe360, vendor=<optimized out>) at ../../../src/EGL/libegl.c:861
#9  0xb4cd9606 in eglMakeCurrent (dpy=<optimized out>, draw=<optimized out>, read=0x1b8e9f0, context=0x19fe5c0) at ../../../src/EGL/libegl.c:727
#10 0xb674a1bd in _cogl_winsys_egl_make_current (display=0x19ca4d8, draw=0x1b8e9f0, read=0x1b8e9f0, context=0x19fe5c0) at winsys/cogl-winsys-egl.c:300
#11 0xb6d8f1f6 in meta_renderer_native_create_view (renderer=0x19c8610, logical_monitor=0x19bbf20) at backends/native/meta-renderer-native.c:2949
#12 0xb6ceaca4 in meta_renderer_create_view (logical_monitor=<optimized out>, renderer=0x19c8610) at ./backends/meta-renderer.h:36
#13 meta_renderer_rebuild_views (renderer=0x19c8610) at backends/meta-renderer.c:73
#14 0xb6d920fa in meta_stage_native_rebuild_views (stage_native=0x19c2470) at backends/native/meta-stage-native.c:141
#15 0xb6d83ba7 in meta_backend_native_update_screen_size (backend=0x19a48b8, width=1024, height=768) at backends/native/meta-backend-native.c:493
#16 0xb6ccf11a in meta_backend_sync_screen_size (backend=backend@entry=0x19a48b8) at backends/meta-backend-private.h:52
#17 0xb6ccff40 in meta_backend_real_post_init (backend=0x19a48b8) at backends/meta-backend.c:442
#18 0xb6d83f98 in meta_backend_native_post_init (backend=0x19a48b8) at ./backends/meta-backend-private.h:52
#19 0xb6cd053a in meta_backend_post_init (backend=<optimized out>) at backends/meta-backend-private.h:52
#20 meta_clutter_init () at backends/meta-backend.c:1239
#21 0xb6d20323 in meta_init () at core/main.c:598
#22 0x004ad53d in main (argc=<optimized out>, argv=<optimized out>) at ../src/main.c:465

---

From: "Md Ayquassar" <[email-masked]>
Date: Fri, 31 Jan 2020 04:23:20 +0300

First, thanks for a quick response.
Second, is a reassignment to some Mesa package required?
Third, is there anything else I can do as a user to help the developers to bugfix
this? Bug at line 1017 is strange: if there is a NULL dereference there, there
should also probably be one in line 1016 unless someone has a deterministic
concurrent access to that data.
Fourth, I apologize for long delays.I don’t always have the laptop at my direct
disposal.

  31.01.2020, 02:09, Bernhard Übelacker <[email-masked]> Hello Md
  Ayquassar,
  sorry, I did not recognize that you
  seem to have a usrmerge'd system.

  Kind regards,
  Bernhard

  (gdb) bt
  #0 0x00000000 in ?? ()
  #1 0xaf7d2c74 in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
  #2 0xaf7d755e in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
  #3 0xade2d004 in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
  #4 0xade2d812 in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
  #5 0xade9232f in ?? () from /usr/lib/i386-linux-gnu/dri/radeon_dri.so
  #6 0xaf7d29ba in ?? () from /lib/i386-linux-gnu/libEGL_mesa.so.0
  #7 0xaf7c061c in eglMakeCurrent () from /lib/i386-linux-gnu/libEGL_mesa.so.0
  #8 0xb4cd8b58 in ?? () from /lib/i386-linux-gnu/libEGL.so.1
  #9 0xb674a1bd in _cogl_winsys_egl_make_current () from
  /usr/lib/i386-linux-gnu/mutter/libmutter-cogl-3.so
  #10 0xb6d8f1f6 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
  #11 0xb6ceaca4 in meta_renderer_rebuild_views () from
  /lib/i386-linux-gnu/libmutter-3.so.0
  #12 0xb6d920fa in meta_stage_native_rebuild_views () from
  /lib/i386-linux-gnu/libmutter-3.so.0
  #13 0xb6d83ba7 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
  #14 0xb6ccf11a in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
  #15 0xb6ccff40 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
  #16 0xb6d83f98 in ?? () from /lib/i386-linux-gnu/libmutter-3.so.0
  #17 0xb6cd053a in meta_clutter_init () from
  /lib/i386-linux-gnu/libmutter-3.so.0
  #18 0xb6d20323 in meta_init () from /lib/i386-linux-gnu/libmutter-3.so.0
  #19 0x004ad53d in ?? ()
  #20 0xb6aa2b41 in __libc_start_main (main=0x4ad430, argc=1, argv=0xbff2c2a4,
  init=0x4adfa0, fini=0x4ae000, rtld_fini=0xb7f97520 <_dl_fini>,
  stack_end=0xbff2c29c) at ../csu/libc-start.c:308
  #21 0x004ad8d1 in ?? ()
  (gdb)

  Core was generated by `/usr/bin/gnome-shell'.
  Program terminated with signal SIGSEGV, Segmentation fault.
  #0 0x00000000 in ?? ()
  [Current thread is 1 (Thread 0xb1f2eb80 (LWP 899))]
  (gdb) set width 0
  (gdb) set pagination off
  (gdb) bt
  #0 0x00000000 in ?? ()
  #1 0xaf7d2c74 in dri2_egl_surface_alloc_local_buffer (dri2_surf=0x1b8e9f0,
  att=9, format=32) at ../src/egl/drivers/dri2/egl_dri2.c:1017
  #2 0xaf7d755e in dri2_drm_get_buffers_with_format (driDrawable=0x1b73580,
  width=0x1b73598, height=0x1b7359c, attachments=0xbff2bb04, count=2,
  out_count=0xbff2baf8, loaderPrivate=0x1b8e9f0) at
  ../src/egl/drivers/dri2/platform_drm.c:344
  #3 0xade2d004 in radeon_update_renderbuffers (context=0x19e7d60,
  drawable=0x1b73580, front_only=0 '\000') at
  ../src/mesa/drivers/dri/radeon/radeon_common_context.c:421
  #4 0xade2d812 in radeonMakeCurrent (driContextPriv=0x19e7d60,
  driDrawPriv=0x1b73580, driReadPriv=0x1b73580) at
  ../src/mesa/drivers/dri/radeon/radeon_common_context.c:616
  #5 0xade9232f in driBindContext (pcp=0x19e7d60, pdp=0x1b73580, prp=0x1b73580)
  at ../src/mesa/drivers/dri/common/dri_util.c:579
  #6 0xaf7d29ba in dri2_make_current (drv=0x19e5120, disp=0x19e49c0,
  dsurf=0x1b8e9f0, rsurf=0x1b8e9f0, ctx=<optimized out>) at
  ../src/egl/drivers/dri2/egl_dri2.c:1516
  #7 0xaf7c061c in eglMakeCurrent (dpy=0x19e49c0, draw=0x1b8e9f0,
  read=0x1b8e9f0, ctx=0x19fe5c0) at ../src/egl/main/eglapi.c:860
  #8 0xb4cd8b58 in InternalMakeCurrentVendor (dpy=0x19e3dd0, draw=draw@entry=0x1b8e9f0,
  read=0x1b8e9f0, read@entry=0x19c3310, context=0x19fe5c0, apiState=0x19fe360,
  vendor=<optimized out>) at ../../../src/EGL/libegl.c:861
  #9 0xb4cd9606 in eglMakeCurrent (dpy=<optimized out>, draw=<optimized out>,
  read=0x1b8e9f0, context=0x19fe5c0) at ../../../src/EGL/libegl.c:727
  #10 0xb674a1bd in _cogl_winsys_egl_make_current (display=0x19ca4d8,
  draw=0x1b8e9f0, read=0x1b8e9f0, context=0x19fe5c0) at
  winsys/cogl-winsys-egl.c:300
  #11 0xb6d8f1f6 in meta_renderer_native_create_view (renderer=0x19c8610,
  logical_monitor=0x19bbf20) at backends/native/meta-renderer-native.c:2949
  #12 0xb6ceaca4 in meta_renderer_create_view (logical_monitor=<optimized out>,
  renderer=0x19c8610) at ./backends/meta-renderer.h:36
  #13 meta_renderer_rebuild_views (renderer=0x19c8610) at
  backends/meta-renderer.c:73
  #14 0xb6d920fa in meta_stage_native_rebuild_views (stage_native=0x19c2470) at
  backends/native/meta-stage-native.c:141
  #15 0xb6d83ba7 in meta_backend_native_update_screen_size (backend=0x19a48b8,
  width=1024, height=768) at backends/native/meta-backend-native.c:493
  #16 0xb6ccf11a in meta_backend_sync_screen_size (backend=backend@entry=0x19a48b8)
  at backends/meta-backend-private.h:52
  #17 0xb6ccff40 in meta_backend_real_post_init (backend=0x19a48b8) at
  backends/meta-backend.c:442
  #18 0xb6d83f98 in meta_backend_native_post_init (backend=0x19a48b8) at
  ./backends/meta-backend-private.h:52
  #19 0xb6cd053a in meta_backend_post_init (backend=<optimized out>) at
  backends/meta-backend-private.h:52
  #20 meta_clutter_init () at backends/meta-backend.c:1239
  #21 0xb6d20323 in meta_init () at core/main.c:598
  #22 0x004ad53d in main (argc=<optimized out>, argv=<optimized out>) at
  ../src/main.c:465

---

From: Bernhard Übelacker <[email-masked]>
Date: Fri, 31 Jan 2020 23:49:51 +0100

Hello Md Ayquassar,

> Second, is a reassignment to some Mesa package required?

I guess mesa maintainer would have more insight if
that function pointer is allowed to be NULL, there
possibly yes.

I wonder if the content of /var/log/Xorg.0.log* would
reveal some more error messages?
Just for a workaround, does giving nomodeset on the kernel prompt
a different result?

> Third, is there anything else I can do as a user to help the developers
> to bugfix this? Bug at line 1017 is strange: if there is a NULL
> dereference there, there should also probably be one in line 1016 unless
> someone has a deterministic concurrent access to that data.

> https://sources.debian.org/src/mesa/18.3.6-2/src/egl/drivers/dri2/egl_dri2.c/#L1017

I assume line 1017, 1018 and 1019 are one statement, therefore gdb shows 1017.
Further I think the function pointer "dri2_dpy->dri2->allocateBuffer"
contains the NULL, therefore the "ip 00000000" in your dmesg output.
A "regular" segfault should still show a sane instruction pointer value.

Kind regards,
Bernhard

---

From: "Md Ayquassar" <[email-masked]>
Date: Sat, 1 Feb 2020 20:44:04 +0300

In the attachment you find /var/log/Xorg.0.log. It contains some error message.
Concerning nomodeset: can I add it during boot process when the grub screen pops
up?

---

From: "Md Ayquassar" <[email-masked]>
Date: Sat, 1 Feb 2020 21:00:01 +0300

I added nomodeset as described in https://askubuntu.com/a/38834 . Then, the boot
process displayed some error concerning UMS and radeon early in the process, and
the screen resolution is different. The boot process still gets stuck, and
switching with Ctrl+Alt+F1 followed by Ctrl+Alt+F2 makes it continue, but the
segfault message disappears from dmesg.

---

From: "Md Ayquassar" <[email-masked]>
Date: Sat, 1 Feb 2020 21:22:14 +0300

affects 948288 + libegl-mesa0thanks
--

With nomodeset kernel option, here is the output of "dmesg" and "journalctl
--no-pager" right after the boots process gets stuck and I switch to console with
Ctrl+Alt+F2. Observe that the segfault message is gone.

I think that the Mesa dirver in any case needs better error handling at the
source code position mentioned. I neither know what the driver does nor what it
is supposed to do, but getting stuck or segfaulting as the last resort does not
seem to be a very useful behavior :-). So, the maintainers of libegl-mesa0 should
become aware of the bug report. So, I did "affects 948288 + libegl-mesa0"; feel
free to correct if you fel otherwise.

---

From: "Md Ayquassar" <[email-masked]>
Date: Sun, 2 Feb 2020 21:30:57 +0300

Dear Bernhard,

As to what happens with nomodeset, I posted another bug report against gdm3:
http://bugs.debian.org/950504. There, we probably won't have to deal with a
gnome-shell segfault and Mesa issues that we have to deal with here.

Best regards,
Md Ayquassar

---

From: "Md Ayquassar" <[email-masked]>
Date: Sun, 2 Feb 2020 21:47:26 +0300

affects 948288 gdm3

affects 950504 gnome-shell

--

In http://bugs.debian.org/948288 , we deal with a segfault of gnome-shell and
Mesa issues using the default kernel command line without nomodeset. In
http://bugs.debian.org/950504, we deal with the boot process getting stuck when
nomodeset option in the kernel command line.

---

From: "Md Ayquassar" <[email-masked]>
Date: Sun, 2 Feb 2020 22:31:04 +0300

... that circumvents both problems but does not solve them turns out to be
disabling Wayland and sticking with Xorg by means of changing
#WaylandEnable=false
to
WaylandEnable=false

in /etc/gdm3/daemon.conf and rebooting. The original problems didn't go away, of
course; the bugs still persist in whichever state they might be.

---

From: "Md Ayquassar" <[email-masked]>
Date: Tue, 5 May 2020 14:07:45 +0300

After libegl-mesa0 was updated to 18.3.6-2+deb10u1, the bug is still reproducible
on the fresh installation. Who of the (upstream?) folks needs to be bothered?
Bernhard, we could send something like

reassign 948288 libegl-mesa0 18.3.6-2+deb10u1
affects 948288 gnome-shell
affects 948288 gdm3
to the control server. What do you think?

Md

---

From: Bernhard Übelacker <[email-masked]>
Date: Tue, 5 May 2020 14:56:48 +0200

Hello Md,
not involved in packaging or development I was just trying
to collect more information about the crash for the maintainer.
I guess reassigning might not be a bad idea and might
give some feedback.
Another option would be to open an issue in the upstream
bug tracker (please put links here and there if you do so).
Also it might be helpful, if you could check if current testing
is still affected. One way to check this could be the live CDs in [1].

Kind regards,
Bernhard

[1] https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/weekly-live-builds/amd64/iso-hybrid/

---

From: "Debian Bug Tracking System" <[email-masked]>
Date: Mon, 21 Apr 2025 18:36:07 +0000

This is an automatic notification regarding your Bug report
which was filed against the gnome-shell package:

#948288: gnome-shell reproducibly crashes on boot, and the boot process gets stuck

It has been closed by Jeremy Bícha <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Jeremy Bícha <[email-masked]> by
replying to this email.

-- 
948288: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=948288
Debian Bug Tracking System
Contact [email-masked] with problems

Subject: closing old GNOME Shell bugs
From: Jeremy Bícha <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
Date: Mon, 21 Apr 2025 14:32:54 -0400

There have been many changes to Debian since this bug was originally
reported. If you are still experiencing this issue with Debian 12 (or
with Testing or Unstable), please report a new bug.

Thank you,
Jeremy Bícha

Subject: gnome-shell reproducibly crashes on boot, and the boot process gets stuck
From: "Md Ayquassar" <[email-masked]>
To: [email-masked]
Date: Mon, 6 Jan 2020 19:38:27 +0300

Package: gnome-shell

...