Subject: lintian.d.o: Provide archive-wide statistics on home page

From: Felix Lechner <[email-masked]>
Date: Thu, 4 Jun 2020 11:24:45 -0700

Control: retitle -1 lintian.d.o: Provide archive-wide statistics on home page

Hi s3v,

> I would like to see stats of Lintian's tags get restored on the main web
> page of the project.

First of all, sorry our web service has been spotty. We hope it will
become one of people's favorite interfaces to research issues in
Debian packages.

Your request predates my involvement but I would like to understand
how to make our data more meaningful on an archive level. (The
'archive' is actually a fluid set of packages that is constantly
synchronized via dakweb.) I can find meaning only by slicing the data
in other dimensions, such as by architecture, or by providing
normalized averages, such as tags per package or overrides per
package, and so on.

Below you will find an old snapshot from the Internet Archive's
Wayback Machine. Which data was most useful to you, please, and why?

Kind regards,
Felix Lechner

* * *

Archives

The following archives are processed by Lintian:

Archive nameAttributeAttribute value
debianArchitecturesi386 amd64
Distributions/Suitesunstable experimental
Componentsmain contrib non-free
Mirror timestampSun, 21 Apr 2019 20:30:22 +0000
debian-debugArchitecturesi386 amd64
Distributions/Suitesunstable-debug experimental-debug
Componentsmain contrib non-free
Mirror timestampSun, 21 Apr 2019 20:30:22 +0000

Statistics

Last updated: Mon, 22 Apr 2019 00:33:21 +0000
Maintainers: 2423 (+0)
Package groups: 31284 (+5)
Rescheduled groups: 3 (+0)
Groups with processing errors: 3 (+0)
Source packages: 29929 (+1)
Binary packages: 39928 (-3)
μdeb packages: 225 (+0)
E Errors: 32305 (+4)
W Warnings: 186976 (-6)
I Info tags: 575740 (-196)
P Pedantic tags: 175454 (-42)
O Overridden tags: 181682 (-138)
X Experimental tags: 124653 (+25)
Lintian version: 2.12.0

(The numbers in parentheses describe the changes since the last
Lintian report, published on Sun, 21 Apr 2019 00:28:21 +0000.)

---

From: s3v <[email-masked]>
Date: Tue, 9 Jun 2020 22:31:04 +0200

Hi Felix,

thanks for your reply e for taking care of package shape via Lintian.
I much appreciated your huge restyling activity and your tons of commits
addressed to make Lintian's internals more performant and consistent.

First of all I have to make clear that my observations come from my *user*
point of view, I'm pretty sure that a plenty of useful statistics can be
pulled out for a Debian Developer [1] or other users.

> normalized averages, such as tags per package or overrides per

Definitively per-tag statistics.

> Mirror timestampSun, 21 Apr 2019 20:30:22 +0000

Doesn't matter archive witch stats come from, nor archs involved.
Aggregate them is a perfect solution for me.
As side note, experimental repository, from my point of view, have little
interest for users. Given ephemeral nature of stuff in experimental, I
think users are not motivated to report bug against this kind of packages
nor make aware developers about problems in files of functionalities that
may disappear the day after.

Anyway, my usual workflow was to follow "List of emitted tags grouped by
severity" link, than I used to check "error" tags or tags emitted for spotting
errors in package descriptions. Sometimes tag names didn't have an immediate
meaning but their web pages are explanatory enough.
So nevermind.

> Groups with processing errors: 3 (+0)

I think these stats are for the sake of Lintian Developers...
I never knew what those meant :)

> P Pedantic tags: 175454 (-42)

All of these are very useful.

> O Overridden tags: 181682 (-138)

Overrides represents stat makes me put in anger the most, and
I consider them an easy way to bypass problems instead of fixing
them.

I've always thought overrides should tend to 0 in a reasonable
time, but I see their number is ever growing.
Maybe Lintian have to drop/revisit tags that are more overridden?
Or avoid overrides for a specific tag subset?
Like the previous one, this aspect definitively does not belong to
users as well.

> X Experimental tags: 124653 (+25)

Useful

Sorry for digressing in some point from your request, I hope Lintian
web pages become a useful instrument for Debian users and Developers.
Deb packages needs to be functional, compliant and.... nice to see :)
Only this matters.

Thanks again for your work.

P.S.
Can you restore on the mainpage the link pointing to the git repo?

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=945544