Subject: tracker.d.o: please integrate information from buildinfos.debian.net

From: Holger Levsen <[email-masked]>
Date: Tue, 31 Mar 2020 19:07:27 +0200

Package: tracker.debian.org
Severity: wishlist

Dear Maintainer,

please integrate information from buildinfos.debian.net into tracker.d.o,
which is a different view/aspect of reproducible builds of Debian packages than
the one currently integrated.

The current one is about the results from tests.reproducible-builds.org/debian
and shows the theoretical reproducibility of a given package. (Two builds are
done and compared.)

The information we would like to have integrated into tracker.d.o is a
link to .buildinfo files for source packages, based on the architecture
the build was done. These .buildinfo files are available on 
buildinfos.debian.net, here's some more background information on
that service:

https://buildinfos.debian.net/ provides .buildinfo files for packages
distributed on ftp.debian.org. Two views are available:

https://buildinfos.debian.net/ftp-master.debian.org/ is a public copy
of /srv/ftp-master.debian.org/buildinfo/ from ftp-master.debian.org.
This data is organized by build dates, which is little useful to most.

https://buildinfos.debian.net/buildinfo-pool/ provides a pool structure
of this data, for example to https://buildinfos.debian.net/buildinfo-pool/libf/libfakekey/libfakekey_0.1-10_hurd-i386.buildinfo

https://buildinfos.debian.net/buildinfo-pool.list is one 66mb file,
listing all currently known .buildinfo for Debian packages distributed
via ftp-master.d.o since 2016-12-22.

This excludes
- builds done before 2016-12-22.
- builds not done on buildds.
- security updates not yet re-released via a point update.
- and probably some more.

In future we probably would like to export a json dump of a postgresql
db, so that the data will become easier to parse. Not sure if this is
needed for the tracker.d.o side to get started?

Feedback welcome!

-- 
cheers,
	Holger

-------------------------------------------------------------------------------
               holger@(debian|reproducible-builds|layer-acht).org
       PGP fingerprint: B8BF 5413 7B09 D35C F026 FE9D 091A B856 069A AA1C

---

From: Paul Wise <[email-masked]>
Date: Wed, 1 Apr 2020 02:52:27 +0000

On Tue, Mar 31, 2020 at 5:09 PM Holger Levsen wrote:

> the build was done.
...
> of this data, for example to https://buildinfos.debian.net/buildinfo-pool/libf/libfakekey/libfakekey_0.1-10_hurd-i386.buildinfo

It sounds like something like this is what is wanted in the links panel?

buildd: logs, ... <a
href="https://buildinfos.debian.net/buildinfo-pool/libf/libfakekey/"
title=".buildinfo files for official builds">info</a>

-- 
bye,
pabs

https://wiki.debian.org/PaulWise

---

From: Holger Levsen <[email-masked]>
Date: Sat, 2 May 2020 11:41:11 +0000

> title=".buildinfo files for official builds">info</a>

yes, that would be awesome. & sorry it took me so long to reply.

-- 
cheers,
	Holger