Subject: gnome-shell: gnome screen lock and screen blank no longer works after 3.36.2-1 update

From: terroreek <[email-masked]>
Date: Wed, 06 May 2020 23:26:29 -0400

Package: gnome-shell
Version: 3.36.2-1
Severity: normal

Dear Maintainer,

After the upgrades from gnome-shell 3.36.2-1 screen locking pressing super + l or from the menu to and screen locking
no longer works.  I have noticed Screen blanking, is also no longer working.  

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.6.11-towo.1-siduction-amd64 (SMP w/48 CPU cores; PREEMPT)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE
Locale: LANG=en_CA.utf8, LC_CTYPE=en_CA.utf8 (charmap=UTF-8), LANGUAGE=en_CA.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gnome-shell depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.36.0-1
ii  evolution-data-server                        3.36.2-1
ii  gir1.2-accountsservice-1.0                   0.6.55-2
ii  gir1.2-atspi-2.0                             2.36.0-2
ii  gir1.2-freedesktop                           1.64.1-1
ii  gir1.2-gcr-3                                 3.36.0-2
ii  gir1.2-gdesktopenums-3.0                     3.36.1-1
ii  gir1.2-gdm-1.0                               3.34.1-3
ii  gir1.2-geoclue-2.0                           2.5.6-1
ii  gir1.2-glib-2.0                              1.64.1-1
ii  gir1.2-gnomebluetooth-1.0                    3.34.1-1
ii  gir1.2-gnomedesktop-3.0                      3.36.2-1
ii  gir1.2-gtk-3.0                               3.24.18-1
ii  gir1.2-gweather-3.0                          3.36.0-1
ii  gir1.2-ibus-1.0                              1.5.22-4
ii  gir1.2-mutter-6                              3.36.2-1
ii  gir1.2-nm-1.0                                1.23.90-1
ii  gir1.2-nma-1.0                               1.8.28-2
ii  gir1.2-pango-1.0                             1.44.7-4
ii  gir1.2-polkit-1.0                            0.105-26
ii  gir1.2-rsvg-2.0                              2.48.4-1
ii  gir1.2-soup-2.4                              2.70.0-1
ii  gir1.2-upowerglib-1.0                        0.99.11-1
ii  gjs                                          1.64.2-1
ii  gnome-backgrounds                            3.36.0-1
ii  gnome-settings-daemon                        3.36.1-1
ii  gnome-shell-common                           3.36.2-1
ii  gsettings-desktop-schemas                    3.36.1-1
ii  libatk-bridge2.0-0                           2.34.1-3
ii  libatk1.0-0                                  2.36.0-2
ii  libc6                                        2.30-7
ii  libcairo2                                    1.16.0-4
ii  libecal-2.0-1                                3.36.2-1
ii  libedataserver-1.2-24                        3.36.2-1
ii  libgcr-base-3-1                              3.36.0-2
ii  libgdk-pixbuf2.0-0                           2.40.0+dfsg-4
ii  libgirepository-1.0-1                        1.64.1-1
ii  libgjs0g                                     1.64.2-1
ii  libgles2                                     1.3.1-1
ii  libglib2.0-0                                 2.64.2-1
ii  libglib2.0-bin                               2.64.2-1
ii  libgnome-autoar-0-0                          0.2.4-2
ii  libgnome-desktop-3-19                        3.36.2-1
ii  libgraphene-1.0-0                            1.10.0-1
ii  libgstreamer1.0-0                            1.16.2-2
ii  libgtk-3-0                                   3.24.18-1
ii  libical3                                     3.0.8-1
ii  libjson-glib-1.0-0                           1.4.4-2
ii  libmutter-6-0                                3.36.2-1
ii  libnm0                                       1.23.90-1
ii  libpango-1.0-0                               1.44.7-4
ii  libpangocairo-1.0-0                          1.44.7-4
ii  libpolkit-agent-1-0                          0.105-26
ii  libpolkit-gobject-1-0                        0.105-26
ii  libpulse-mainloop-glib0                      13.0-5
ii  libpulse0                                    13.0-5
ii  libsecret-1-0                                0.20.3-1
ii  libsystemd0                                  245.5-2
ii  libwayland-server0                           1.18.0-1
ii  libx11-6                                     2:1.6.9-2+b1
ii  libxfixes3                                   1:5.0.3-2
ii  mutter                                       3.36.2-1
ii  python3                                      3.8.2-3

Versions of packages gnome-shell recommends:
ii  bolt                  0.8-4
ii  chrome-gnome-shell    10.1-5
ii  gdm3                  3.34.1-3
ii  gkbd-capplet          3.26.1-1
ii  gnome-control-center  1:3.36.2-1
ii  gnome-menus           3.36.0-1
ii  gnome-user-docs       3.36.2-1
ii  ibus                  1.5.22-4
ii  iio-sensor-proxy      3.0-1
ii  switcheroo-control    2.1-1
ii  unzip                 6.0-25

Versions of packages gnome-shell suggests:
pn  gir1.2-telepathyglib-0.12   <none>
pn  gir1.2-telepathylogger-0.2  <none>

Versions of packages gnome-session depends on:
ii  gnome-session-bin      3.36.0-2+b1
ii  gnome-session-common   3.36.0-2
ii  gnome-settings-daemon  3.36.1-1

Versions of packages gnome-session suggests:
ii  desktop-base   10.0.3
ii  gnome-keyring  3.36.0-1

Versions of packages gnome-settings-daemon depends on:
ii  gnome-settings-daemon-common  3.36.1-1
ii  gsettings-desktop-schemas     3.36.1-1
ii  libasound2                    1.2.2-2.1
ii  libc6                         2.30-7
ii  libcairo2                     1.16.0-4
ii  libcanberra-gtk3-0            0.30-7
ii  libcanberra0                  0.30-7
ii  libcolord2                    1.4.4-2
ii  libcups2                      2.3.3-1
ii  libfontconfig1                2.13.1-4
ii  libgcr-base-3-1               3.36.0-2
ii  libgdk-pixbuf2.0-0            2.40.0+dfsg-4
ii  libgeoclue-2-0                2.5.6-1
ii  libgeocode-glib0              3.26.2-2
ii  libglib2.0-0                  2.64.2-1
ii  libgnome-desktop-3-19         3.36.2-1
ii  libgtk-3-0                    3.24.18-1
ii  libgudev-1.0-0                233-1
ii  libgweather-3-16              3.36.0-1
ii  liblcms2-2                    2.9-4+b1
ii  libmm-glib0                   1.12.8-1.1
ii  libnm0                        1.23.90-1
ii  libnotify4                    0.7.9-1
ii  libnspr4                      2:4.25-1
ii  libnss3                       2:3.52-1
ii  libpam-systemd [logind]       245.5-2
ii  libpango-1.0-0                1.44.7-4
ii  libpangocairo-1.0-0           1.44.7-4
ii  libpolkit-gobject-1-0         0.105-26
ii  libpulse-mainloop-glib0       13.0-5
ii  libpulse0                     13.0-5
ii  libupower-glib3               0.99.11-1
ii  libwacom2                     1.3-2
ii  libwayland-client0            1.18.0-1
ii  libx11-6                      2:1.6.9-2+b1
ii  libxext6                      2:1.3.3-1+b2
ii  libxi6                        2:1.7.9-1

Versions of packages gnome-settings-daemon recommends:
ii  iio-sensor-proxy   3.0-1
ii  pulseaudio         13.0-5
ii  x11-xserver-utils  7.7+8

Versions of packages gnome-settings-daemon suggests:
pn  usbguard  <none>

Versions of packages libgjs0g depends on:
ii  libc6                  2.30-7
ii  libcairo-gobject2      1.16.0-4
ii  libcairo2              1.16.0-4
ii  libffi7                3.3-4
ii  libgcc-s1              10-20200502-1
ii  libgirepository-1.0-1  1.64.1-1
ii  libglib2.0-0           2.64.2-1
ii  libmozjs-68-0          68.7.0-1
ii  libreadline8           8.0-4
ii  libstdc++6             10-20200502-1
ii  libx11-6               2:1.6.9-2+b1

Versions of packages gnome-shell is related to:
ii  libegl-mesa0 [libegl-vendor]    20.0.6-1
ii  libgl1-mesa-dri                 20.0.6-1
ii  libglx-mesa0 [libglx-vendor]    20.0.6-1
ii  libglx-nvidia0 [libglx-vendor]  440.82-1
ii  nvidia-egl-icd [libegl-vendor]  440.82-1

-- no debconf information

---

From: Simon McVittie <[email-masked]>
Date: Thu, 7 May 2020 08:39:06 +0100

Control: tags -1 + moreinfo

On Wed, 06 May 2020 at 23:26:29 -0400, terroreek wrote:
> After the upgrades from gnome-shell 3.36.2-1 screen locking pressing
> super + l or from the menu to and screen locking

Are you using any GNOME Shell extensions? If you are, does this problem
persist when you disable them using gnome-shell-extension-prefs or
gnome-tweaks?

When you try to lock the screen, what messages appear in the systemd
journal?

(This is working fine for me; I suspect others in the GNOME team would
also quickly notice if the lock screen was entirely broken.)

> Kernel: Linux 5.6.11-towo.1-siduction-amd64 (SMP w/48 CPU cores; PREEMPT)

siduction is not Debian (it's a derivative with some modified packages,
like Ubuntu), and if a bug is not reproducible on a purely Debian system
we are unlikely to be able to fix it.

    smcv

---

From: terroreek <[email-masked]>
Date: Thu, 7 May 2020 06:38:13 -0400

Yep, looks like it was the gtile extension.  I turned it off and now all is
working.  I will report the issue to the extension.