Subject: simple-cdd: Support local apt cache

From: John Franklin <[email-masked]>
Date: Sun, 21 Jun 2020 12:39:20 -0400

Package: simple-cdd
Version: 0.6.7
Severity: wishlist

Reprepro supports using apt caches via apts "Acquire::http::Proxy" setting.  It
would be nice to expose this to simple-cdd.

See PR at https://salsa.debian.org/debian/simple-cdd/-/merge_requests/3

-- System Information:
Debian Release: 10.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.5.0-0.bpo.2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages simple-cdd depends on:
ii  dctrl-tools         2.24-3
ii  debian-cd           3.1.25
ii  lsb-release         10.2019051400
ii  python3             3.7.3-1
ii  python3-simple-cdd  0.6.7
ii  reprepro            5.3.0-1
ii  rsync               3.1.3-6
ii  wget                1.20.1-1.1

Versions of packages simple-cdd recommends:
ii  dose-distcheck  5.0.1-12

Versions of packages simple-cdd suggests:
ii  qemu-kvm  1:3.1+dfsg-8+deb10u5

-- no debconf information

---

From: Vagrant Cascadian <[email-masked]>
Date: Sun, 21 Jun 2020 10:09:35 -0700

> See PR at https://salsa.debian.org/debian/simple-cdd/-/merge_requests/3

Thanks for the pull request!

I've always used http_proxy, is this somehow not sufficient for your
use-case?

live well,
  vagrant