Subject: openjdk-11-jre-headless: manpages describe JDK8, last updated in 2015

From: Jonathan Dowland <[email-masked]>
Date: Wed, 26 Aug 2020 15:02:44 +0100

Package: openjdk-11-jre-headless
Version: 11.0.8+10-1~deb10u1
Severity: normal

/usr/lib/jvm/java-11-openjdk-amd64/man/man1/java.1.gz describes JDK8,
and omits descriptions of e.g. -Xpatch.  The bottom line of the manpage
reads

    JDK 8            03 March 2015      java(1)

I've only checked that one, I don't know about the others.

-- System Information:
Debian Release: 10.2
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-debug'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-6-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_WARN
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), LANGUAGE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages openjdk-11-jre-headless depends on:
ii  ca-certificates-java  20190405
ii  java-common           0.71
ii  libasound2            1.1.8-1
ii  libc6                 2.28-10
ii  libcups2              2.2.10-6+deb10u3
ii  libfontconfig1        2.13.1-2
ii  libfreetype6          2.9.1-3+deb10u1
ii  libgcc1               1:8.3.0-6
ii  libjpeg62-turbo       1:1.5.2-2+b1
ii  liblcms2-2            2.9-3
ii  libnss3               2:3.42.1-1+deb10u2
ii  libpcsclite1          1.8.24-1
ii  libstdc++6            8.3.0-6
ii  libx11-6              2:1.6.7-1
ii  libxext6              2:1.3.3-1+b2
ii  libxi6                2:1.7.9-1
ii  libxrender1           1:0.9.10-1
ii  libxtst6              2:1.2.3-1
ii  util-linux            2.33.1-0.1
ii  zlib1g                1:1.2.11.dfsg-1

openjdk-11-jre-headless recommends no packages.

Versions of packages openjdk-11-jre-headless suggests:
ii  fonts-dejavu-extra                     2.37-1
pn  fonts-indic                            <none>
pn  fonts-ipafont-gothic                   <none>
pn  fonts-ipafont-mincho                   <none>
pn  fonts-wqy-microhei | fonts-wqy-zenhei  <none>
ii  libnss-mdns                            0.14.1-1

-- no debconf information

---

From: Thorsten Glaser <[email-masked]>
Date: Sun, 22 Nov 2020 17:31:45 +0100

Package: openjdk-11-jdk-headless
Version: 11.0.9.1+1-1
Followup-For: Bug #969038
X-Debbugs-Cc: [email-masked]

Yes, please *do* take care of this, ideally also in buster,
as this seriously degrades the usability of the software.

For example, JDK 8 had javah but JDK 11 doesn’t, and it’s
supposed to be replaced by some javac option, which now is
not documented.

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'oldstable-updates'), (500, 'buildd-unstable'), (500, 'unstable'), (500, 'oldstable'), (1, 'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.9.0-2-amd64 (SMP w/2 CPU threads)
Kernel taint flags: TAINT_WARN
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

Versions of packages openjdk-11-jdk-headless depends on:
ii  libc6                    2.31-4
ii  openjdk-11-jre-headless  11.0.9.1+1-1

openjdk-11-jdk-headless recommends no packages.

Versions of packages openjdk-11-jdk-headless suggests:
pn  openjdk-11-demo    <none>
ii  openjdk-11-source  11.0.9.1+1-1