Subject: Bug#970582: network-manager-gnome: nm-applet does not recognize NetworkManager service (LXDE)

From: "Hans-J. Ullrich" <[email-masked]>
Date: Sat, 19 Sep 2020 12:24:06 +0200

Package: network-manager-gnome
Version: 1.18.0-1
Severity: important

Dear Maintainer,

the system here is debian/testing and the following bug appeared on i386 and amd64.

I am not quite sure if this is the same as bug #770989, but i changed from wicd to network-manager.

When starting LXDE from lightdm, I see nm-applet in the taskbar, but when clicking on it, it says networkservice not running.

However, it looks for me either as a rights problem (which would lead to bug #770989) or it is just a timing problem. Timing problem, because, if I kill nm-applet and stop NetworkManager manually and restart it (using "service NetworkManager stop" and "service Networkmanager start") and then start nm-applet again, this works.

Please also note, that plasma-nm is working well in plasma5, and if I start nm-applet in plasma5, it is working also well.

Please also note: Before I am starting LXDE, I checked that the process Networkmanager is running by calling "systemctl status NetworkManager".

So I believe: Either rights problem or timing problem.

It would be nice, if you could have a look at it, because Network-manager is an important package and as wicd has no removed, there is no alternative at the moment for it.

Thank you very much for any help!

Best regards

Hans

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.8.0-1-amd64 (SMP w/2 CPU threads)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE=de
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages network-manager-gnome depends on:
ii  dbus-user-session [default-dbus-session-bus]  1.12.20-1
ii  dbus-x11 [dbus-session-bus]                   1.12.20-1
ii  libatk1.0-0                                   2.36.0-2
ii  libayatana-appindicator3-1                    0.5.5-2
ii  libc6                                         2.31-3
ii  libcairo2                                     1.16.0-4
ii  libgdk-pixbuf2.0-0                            2.40.0+dfsg-5
ii  libglib2.0-0                                  2.66.0-2
ii  libgtk-3-0                                    3.24.23-1
ii  libjansson4                                   2.13.1-1
ii  libmm-glib0                                   1.14.2-0.1
ii  libnm0                                        1.26.2-1
ii  libnma0                                       1.8.30-1
ii  libnotify4                                    0.7.9-1
ii  libpango-1.0-0                                1.46.1-1
ii  libpangocairo-1.0-0                           1.46.1-1
ii  libsecret-1-0                                 0.20.3-1
ii  libselinux1                                   3.1-2
ii  lxqt-policykit [polkit-1-auth-agent]          0.14.1-1+b1
ii  network-manager                               1.26.2-1
ii  policykit-1-gnome [polkit-1-auth-agent]       0.105-7
ii  polkit-kde-agent-1 [polkit-1-auth-agent]      4:5.17.5-2

Versions of packages network-manager-gnome recommends:
ii  gnome-keyring                             3.36.0-1
ii  iso-codes                                 4.5.0-1
ii  lxqt-notificationd [notification-daemon]  0.14.1-1+b1
ii  mobile-broadband-provider-info            20190618-3
ii  notification-daemon                       3.20.0-4
ii  notify-osd [notification-daemon]          0.9.35+15.04.20150126-1+b1
ii  plasma-workspace [notification-daemon]    4:5.17.5-4

Versions of packages network-manager-gnome suggests:
pn  network-manager-openconnect-gnome  <none>
pn  network-manager-openvpn-gnome      <none>
pn  network-manager-pptp-gnome         <none>
pn  network-manager-vpnc-gnome         <none>

-- debconf-show failed

---

From: Hans <[email-masked]>
Date: Sat, 19 Sep 2020 13:11:12 +0200

Additional info: I am now pretty sure, that indeed is a timing problem, not a 
rights problem.

Why? Well, if I start the computer and start LXDE, nm-applet says: 
NetworkManager not running (however, it is running!).

Simply stop LXDE and start it again, so voila, everything is working well.

That let me to the conclusion: Something is not quite starting well at boot, 
maybe NetworkManager is still not available or still starting in progress, at 
the time, nm-applet is starting.

But when you do this manually in the right time: Networkmanager -> LXDE -> nm-
applet, this works.

Would be nice, if you could take care of this, maybe this might also fix other 
bugreports.

Best regards

Hans