Subject: amavisd-new: Recommends unavailable package ripole

From: Mathias Behrle <[email-masked]>
Date: Fri, 9 Oct 2020 09:30:13 +0200

Package: amavisd-new
Version: 1:2.11.0-6.1
Severity: important

Dear Maintainer,

package ripole is not available in buster, but still listed in Recommends.

Cheers
Mathias

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing
  APT policy: (800, 'testing'), (700, 'unstable'), (600, 'experimental'), (500,
'stable') Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.8.0-2-amd64 (SMP w/4 CPU threads)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages amavisd-new depends on:
ii  adduser                    3.118
ii  debconf [debconf-2.0]      1.5.74
ii  file                       1:5.38-5
ii  init-system-helpers        1.58
pn  libarchive-tar-perl        <none>
ii  libarchive-zip-perl        1.68-1
pn  libberkeleydb-perl         <none>
pn  libconvert-tnef-perl       <none>
pn  libconvert-uulib-perl      <none>
pn  libdigest-md5-perl         <none>
ii  libio-stringy-perl         2.111-3
pn  libmail-dkim-perl          <none>
ii  libmailtools-perl          2.21-1
pn  libmime-base64-perl        <none>
ii  libmime-tools-perl         5.509-1
pn  libnet-libidn-perl         <none>
pn  libnet-server-perl         <none>
pn  libunix-syslog-perl        <none>
ii  lsb-base                   11.1.0
pn  pax                        <none>
ii  perl [libtime-hires-perl]  5.30.3-4

Versions of packages amavisd-new recommends:
pn  altermime             <none>
pn  libnet-patricia-perl  <none>
pn  ripole                <none>

Versions of packages amavisd-new suggests:
ii  apt-listchanges      3.22
pn  arj                  <none>
pn  cabextract           <none>
pn  clamav               <none>
pn  clamav-daemon        <none>
ii  cpio                 2.13+dfsg-4
pn  dspam                <none>
pn  lhasa                <none>
ii  libauthen-sasl-perl  2.1600-1
pn  libdbi-perl          <none>
pn  libmail-dkim-perl    <none>
pn  libnet-ldap-perl     <none>
pn  libsnmp-perl         <none>
pn  libzeromq-perl       <none>
ii  lzop                 1.04-1
pn  nomarch              <none>
ii  p7zip                16.02+dfsg-8
ii  rpm                  4.14.2.1+dfsg1-1.1+b1
pn  spamassassin         <none>
pn  unrar                <none>

---

From: [email-masked]
Date: Sun, 02 Mar 2025 20:35:49 +0000

Source: amavisd-new
Version: 1:2.13.0-6
Justification: 2.2.1
Followup-For: Bug #971896
Control: severity -1 serious

Dear Maintainer,

recommending a package that is not present in debian main is considered
a violation of a 'must' directive of the debian policy, which carries a
'serious' severity for bug reports.

Debian policy [1] states:
"the packages in main must not require or recommend a package outside of
main for compilation or execution (thus, the package must not declare a
Pre-Depends, Depends, Recommends, Build-Depends, Build-Depends-Indep, or
Build-Depends-Arch relationship on a non-main package unless that
package is only listed as a non-default alternative for a package in
main)"

Please review your package dependencies so that they are aligned with
the debian policy. Thanks.

[1] https://www.debian.org/doc/debian-policy/ch-archive.html#the-main-archive-area