Subject: qdbus: Needs package downgrade from Buster to Bullseye (missing epoch in transitional package)

From: Axel Beckert <[email-masked]>
Date: Thu, 18 Feb 2021 09:08:46 +0100

Package: qdbus
Severity: serious
Justification: §3.2 and https://wiki.debian.org/SystemDowngrade

Hi,

on one system I wondered why qdbus is still on Qt4. Then I noticed that
the version of the Qt4 qdbus package from Buster is higher (!) than the
version of the Qt5 qdbus package in Bullseye:

$ apt-cache policy qdbus
qdbus:
  Installed: 4:4.8.7+dfsg-18+deb10u1
  Candidate: 4:4.8.7+dfsg-18+deb10u1
  Version table:
 *** 4:4.8.7+dfsg-20 100
        100 /var/lib/dpkg/status
     5.15.2-3 990
        900 https://debian.ethz.ch/debian bullseye/main i386 Packages

>From what I can see, the proper fix is to prepend at least an epoch of
"4" to (only) the transitional package, i.e. to make the version of
qdbus in Bullseye "4:5.15.2-…" instead of just "5.15.2-…".

Even the BTS gets it partially wrong probably because of this and still
thinks the current qdbus package is built from the qt4-x11 source
package:

https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=qdbus;dist=unstable
(Note that it displays the correct version number, but the wrong source
package.)

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (600, 'testing'), (500, 'unstable-debug'), (500, 'buildd-unstable'), (110, 'experimental'), (1, 'experimental-debug'), (1, 'buildd-experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.10.0-1-amd64 (SMP w/4 CPU threads)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)
LSM: AppArmor: enabled

---

From: Ivo De Decker <[email-masked]>
Date: Fri, 19 Feb 2021 12:30:12 +0100

clone -1 -2
reassign -2 ftp.debian.org
retitle -2 dak: version checks for binaries not enforced when binary changes from any to all
severity -2 normal
tags -2 - pending

Hi,

>   Candidate: 4:4.8.7+dfsg-18+deb10u1

The current situation:

qdbus      | 5.15.2-3                             | testing      | all
qdbus      | 5.15.2-3                             | unstable     | all
qdbus      | 4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1 | oldoldstable | amd64, armel, armhf, i386
qdbus      | 4:4.8.7+dfsg-11                      | oldstable    | amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x
qdbus      | 4:4.8.7+dfsg-18+deb10u1              | stable       | amd64, arm64, armel, armhf, i386, mips, mips64el, mipsel, ppc64el, s390x

Normally, version checks should prevent an upload to unstable of a binary that
has a lower version than in stable or testing. However, this is checked per
architecture, and it seems the check wasn't done because the binary changed
from arch: any to arch: all at the same time. This case should probably be
checked in dak as well (obviously also for arch: all to arch: any).

Cloning the bug to track the issue in dak.

Cheers,

Ivo

---

From: Ivo De Decker <[email-masked]>
Date: Fri, 19 Feb 2021 12:58:07 +0100

clone 983018 -2
thanks

Hi,

The current situation:

Cheers,

Ivo