Subject: Bug#985709: ibus-mozc: mozc-tool ignores KDE Qt theme

From: Daniel Tang <[email-masked]>
Date: Mon, 22 Mar 2021 09:47:17 -0400

Package: ibus-mozc
Version: 2.26.4220.100+dfsg-4ubuntu2
Severity: normal
X-Debbugs-Cc: [email-masked]

This was orignally reported in Ubuntu downstream at
https://bugs.launchpad.net/ubuntu/+source/mozc/+bug/1920578 . I am
reporting it upstream as per the maintainer's instructions.

Summary:

Mozc ignores my KDE Qt theme, and uses the ugly fallback theme.

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu

Description: Ubuntu Hirsute Hippo (development branch)
Release: 21.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

mozc-utils-gui:
  Installed: 2.26.4220.100+dfsg-4ubuntu2
  Candidate: 2.26.4220.100+dfsg-4ubuntu2
  Version table:
 *** 2.26.4220.100+dfsg-4ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu hirsute/universe amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen

The UI should use the configured Qt theme like all Qt applications. For an example of an application with the correct theme, you can open Dolphin, and click the overflow menu, then "Configure Dolphin".

The "OK", "Apply", and "Cancel" buttons are particularly easy to compare.

4) What happened instead

The UI looks very ugly and out of place compared to the rest of the system. It looks like it's falling back to the default Qt theme. It doesn't look like a piece of software bundled with Ubuntu, but rather like downloaded 3rd-party software that bundles its own Qt like Anki (dark mode), Genymotion, Binary Ninja, and (old versions of) MultiMC.

Another relevant comment:

> Assuming you are using Kubuntu, I don't have access to any Kubuntu install ATM

> Do you know if the issue is present in e.g. 20.04 or 20.10 as well?

I spun up Kubuntu 20.04, 20.10, and 21.04 live CD VMs. I found the theming issue is present neither in 20.04 nor 20.10. On those versions, (aside from the one minor problem of the line underneath the tab) the dialog fits in like a native KDE application. It seems like this is a regression introduced in 21.04.

The about box text is still illegible in all three versions.

Attached is the newly-found expected behaviour, as it was in 20.04 and 20.10.

-- System Information:
Debian Release: bullseye/sid
  APT prefers hirsute
  APT policy: (500, 'hirsute')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.11.7-surface (SMP w/8 CPU threads)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages ibus-mozc depends on:
ii  ibus                    1.5.24-1
ii  libabsl20200923         0~20200923.3-3
ii  libc6                   2.33-0ubuntu2
ii  libglib2.0-0            2.67.5-2
ii  libibus-1.0-5           1.5.24-1
ii  libprotobuf23           3.12.4-1ubuntu1
ii  libstdc++6              11-20210310-1ubuntu1
ii  libxcb-xfixes0          1.14-3ubuntu1
ii  libxcb1                 1.14-3ubuntu1
ii  mozc-data               2.26.4220.100+dfsg-4ubuntu2
ii  mozc-server             2.26.4220.100+dfsg-4ubuntu2
ii  tegaki-zinnia-japanese  0.3-1.1

ibus-mozc recommends no packages.

Versions of packages ibus-mozc suggests:
ii  mozc-utils-gui  2.26.4220.100+dfsg-4ubuntu2

-- no debconf information

---

From: Gunnar Hjalmarsson <[email-masked]>
Date: Wed, 24 Mar 2021 11:49:26 +0100

One idea, Daniel:

In your 21.04 installation, can you please manually install version 
2.23.2815.102+dfsg-10build1 of the mozc packages from 20.10. You may 
need to download:

- ibus-mozc
- mozc-data
- mozc-server
- mozc-utils-gui

If that makes the theme issue go away, we have isolated the cause of the 
issue to mozc. Otherwise the cause reasonably lies somewhere else.

-- 
Cheers,

Gunnar Hjalmarsson
https://launchpad.net/~gunnarhj

---

From: Daniel T <[email-masked]>
Date: Wed, 24 Mar 2021 09:37:04 -0400

Dear Mr. Hjalmarsson,

Doing just `dpkg -i mozc-utils-gui_2.23.2815.102+dfsg-10build1_amd64.deb`
does indeed solve the problem.

Sincerely,
Daniel Tang

---

From: Gunnar Hjalmarsson <[email-masked]>
Date: Wed, 24 Mar 2021 18:25:39 +0100

On 2021-03-24 14:37, Daniel T wrote:
> Doing just `dpkg -i 
> mozc-utils-gui_2.23.2815.102+dfsg-10build1_amd64.deb` does indeed solve 
> the problem.

Thanks!

@Nobuhiro: Should this be reported upstream? I don't see anything about 
it in the upstream issue tracker.