Subject: dialect: Network error when starting the application

From: Wellington Almeida <[email-masked]>
Date: Tue, 22 Jun 2021 19:50:56 -0300

Package: dialect
Version: 1.3.0-1
Severity: normal
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 11.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.12.12-gnu (SMP w/2 CPU threads)
Locale: LANG=pt_BR.UTF-8, LC_CTYPE=pt_BR.UTF-8 (charmap=UTF-8),
LANGUAGE=pt_BR:pt:en
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages dialect depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.38.0-2
ii  gir1.2-glib-2.0                              1.66.1-1+b1
ii  gir1.2-gstreamer-1.0                         1.18.4-2
ii  gir1.2-gtk-3.0                               3.24.24-4
ii  gir1.2-handy-1                               1.0.3-2
ii  python3                                      3.9.2-3
ii  python3-dbus                                 1.2.16-5
ii  python3-gi                                   3.38.0-2
ii  python3-gtts                                 2.0.3-1
ii  python3-httpx                                0.16.1-1
ii  python3-langdetect                           1.0.7-4

dialect recommends no packages.

dialect suggests no packages.

---

From: Wellington Almeida <[email-masked]>
Date: Tue, 22 Jun 2021 20:01:57 -0300

Package: dialect
Version: 1.3.0-1
Followup-For: Bug #990207
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

When running the application a network error message occurs and the prompt
displays this message:

(com.github.gi_lom.dialect:2011): Gtk-WARNING **: 19:56:37.314: Negative
content width -47 (allocation 1, extents 24x24) while allocating gadget (node
box, owner GtkBox)
Error: Unable to get language list: 'NoneType' object is not subscriptable

(com.github.gi_lom.dialect:2011): Gtk-WARNING **: 19:56:44.615: Negative
content width -47 (allocation 1, extents 24x24) while allocating gadget (node
box, owner GtkBox)

-- System Information:
Debian Release: 11.0
  APT prefers unstable