Subject: Unable to find the top-level configuration file '/usr/share/alsa/ucm2/ucm.conf'.

From: 積丹尼 Dan Jacobson <[email-masked]>
Date: Sun, 12 Sep 2021 20:20:36 +0800

Package: alsa-utils
Version: 1.2.5.1-1
File: /usr/sbin/alsactl

# alsactl restore
alsa-lib parser.c:2372:(load_toplevel_config) Unable to find the top-level configuration file '/usr/share/alsa/ucm2/ucm.conf'.
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2

---

From: 積丹尼 Dan Jacobson <[email-masked]>
Date: Sun, 26 Sep 2021 14:23:23 +0800

several 994179 critical
thanks

# alsactl restore
alsa-lib parser.c:2372:(load_toplevel_config) Unable to find the top-level configuration file '/usr/share/alsa/ucm2/ucm.conf'.
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
alsa-lib parser.c:2372:(load_toplevel_config) Unable to find the top-level configuration file '/usr/share/alsa/ucm2/ucm.conf'.
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:2 use case configuration -2

One would think that doing

# aptitude install alsa-ucm-conf

a non dependency, would fix it.

Alas, no:

# alsactl restore
alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HD-Audio Generic at 0xfe960000 irq 46)
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6
alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HDA ATI HDMI at 0xfe964000 irq 45)
alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:2 use case configuration -6

https://github.com/alsa-project/alsa-utils/issues/101

https://github.com/alsa-project/alsa-lib/issues/159

https://www.reddit.com/r/archlinux/comments/hz0ef8/feeling_discouraged/

https://bugs.archlinux.org/task/67027

---

From: Elimar Riesebieter <[email-masked]>
Date: Sun, 26 Sep 2021 14:55:07 +0200

Control: severity -1 normal
Control: tags -1 + wontfix

Hi Dan,

severity critical means "makes unrelated software on the system (or
the whole system) break, or causes serious data loss, or introduces
a security hole on systems where you install the package."

So is your system damaged or burned down? Did you loose any data?
Severity reseted hereby.

> https://github.com/alsa-project/alsa-utils/issues/101

According to this issue the error is harmless for the legacy
hardware.

> https://github.com/alsa-project/alsa-lib/issues/159

According to this issue one can add -U parameter to the alsactl call
in the initscripts (systemd or whatever). This issue is tagged
'wonfix' as I do with this bug as well.

Elimar
-- 
    .~.
    /V\   L   I   N   U   X
   /( )\ >Phear the Penguin<
   ^^-^^

---

From: 積丹尼 Dan Jacobson <[email-masked]>
Date: Mon, 27 Sep 2021 04:24:08 +0800

OK I meant serious: "makes the package unsuitable for release."
Because it is now spitting out error messages on every use.