Subject: fwupdmgr: WARNING: Firmware can not be updated in legacy BIOS mode

From: Thorsten Glaser <[email-masked]>
Date: Tue, 28 Sep 2021 22:23:00 +0200

Package: fwupd
Version: 1.5.7-4
Severity: normal
X-Debbugs-Cc: [email-masked]

tglase@tglase-nb:~ $ sudo fwupdmgr get-devices
WARNING: Firmware can not be updated in legacy BIOS mode
  See https://github.com/fwupd/fwupd/wiki/PluginFlag:legacy-bios for more information.
[…]

I’ve followed the instructions on the listed page and added uefi
to the list of disabled plugins, but the message still is shown.

This laptop doesn’t have EFI.

-- System Information:
Debian Release: 11.0
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable-debug'), (500, 'oldstable-updates'), (500, 'oldoldstable'), (500, 'stable'), (500, 'oldstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.10.0-8-amd64 (SMP w/2 CPU threads)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

Versions of packages fwupd depends on:
ii  libc6                      2.31-13
ii  libcurl3-gnutls            7.74.0-1.3+b1
ii  libefiboot1                37-6
ii  libelf1                    0.183-3
ii  libelogind0 [libsystemd0]  246.9.1-1+debian1
ii  libflashrom1               1.2-5
ii  libfwupd2                  1.5.7-4
ii  libfwupdplugin1            1.5.7-4
ii  libglib2.0-0               2.66.8-1
ii  libgnutls30                3.7.1-5
ii  libgudev-1.0-0             234-1
ii  libgusb2                   0.3.5-1
ii  libjcat1                   0.1.3-2
ii  libjson-glib-1.0-0         1.6.2-1
ii  libpolkit-gobject-1-0      0.105-31
ii  libsmbios-c2               2.4.3-1
ii  libsqlite3-0               3.34.1-3
ii  libtss2-esys-3.0.2-0       3.0.3-2
ii  libxmlb1                   0.1.15-2
ii  shared-mime-info           2.0-1

Versions of packages fwupd recommends:
pn  bolt           <none>
ii  dbus           1.12.20-2
pn  fwupd-signed   <none>
ii  python3        3.9.2-3
pn  secureboot-db  <none>
ii  udisks2        2.9.2-2

Versions of packages fwupd suggests:
pn  gir1.2-fwupd-2.0  <none>

-- Configuration Files:
/etc/fwupd/daemon.conf changed:
[fwupd]
DisabledDevices=
DisabledPlugins=test;test_ble;invalid;uefi
ArchiveSizeMax=0
IdleTimeout=7200
VerboseDomains=
UpdateMotd=true
EnumerateAllDevices=false
ApprovedFirmware=
BlockedFirmware=
UriSchemes=

-- no debconf information

---

From: Default User <[email-masked]>
Date: Thu, 07 Oct 2021 18:18:09 -0400

Package: fwupd
Version: 1.5.7-4
Followup-For: Bug #995270
X-Debbugs-Cc: [email-masked]

Dear Maintainer,

This is just a "me too", to validate the experience of the original submitter.
I too encountered this same bug, when the Gnome Software program notified me of
a firmware update for my Logitech Unifying receiver, which I use for my
Logitech k360 wireless usb keyboard and my Logitech m325 wireless usb mouse.

Gnome Software first gave this message:

"Device Firmware

Unifying Receiver Device Update
RQR12.03_B0025 -> RQR12.10_B0032

Device cannot be..ed during update."

But it was unable to perform the update, leaving the mouse and keyboard non-
functional until reboot. It gave this error message:

"Unable to update "Unifying Receiver Device Update": failed to get device after
detatch replug: device 92831be453a0f345462e7050e26a5675d4xxxxxx did not come
back"

Now, Gnome Software taunts me with a persistent notification of this firmware
update, which I cannot do, and I cannot make the notification go away, except
by completely uninstalling the Gnome Software program.

Output from fwupdmgr get-devices includes this:

"WARNING: Firmware can not be updated in legacy BIOS mode
  See https://github.com/fwupd/fwupd/wiki/PluginFlag:legacy-bios for more
information.
Unifying Receiver:
      Device ID:          cd0ca444337ce69f27ebb3fff2dc35c338xxxxxx
      Summary:            A miniaturised USB wireless receiver
      Current version:    RQR12.03_B0025
      Bootloader Version: BOT01.02_B0015
      Vendor:             HIDRAW:0x046D|USB:0x046D
      Install Duration:   30 seconds
      GUIDs:              9d131a0c-a606-580f-8eda-80587250b8d6
                          fcf55bf5-767b-51ce-9c17-f6f538c4ee9f
                          279ed287-3607-549e-bacc-f873bb9838c4
      Device Flags:       • Updatable
                          • Supported on remote server"

Output of fwdupmgr get-updates includes:

"WARNING: Firmware can not be updated in legacy BIOS mode
  See https://github.com/fwupd/fwupd/wiki/PluginFlag:legacy-bios for more
information.
Devices with no available firmware updates:
 • KINGSTON SV300S3xxxxxx
Inspiron 3542
│
└─Unifying Receiver:
  │   Device ID:          cd0ca444337ce69f27ebb3fff2dc35c338xxxxxx
  │   Summary:            A miniaturised USB wireless receiver
  │   Current version:    RQR12.03_B0025
  │   Bootloader Version: BOT01.02_B0015
  │   Vendor:             HIDRAW:0x046D|USB:0x046D
  │   Install Duration:   30 seconds
  │   GUIDs:              9d131a0c-a606-580f-8eda-80587250b8d6
  │                       fcf55bf5-767b-51ce-9c17-f6f538c4ee9f
  │                       279ed287-3607-549e-bacc-f873bb9838c4
  │   Device Flags:       • Updatable
  │                       • Supported on remote server
  │
  ├─Unifying Receiver:
  │     New version:      RQR12.10_B0032
  │     Remote ID:        lvfs
  │     Summary:          Firmware for the Logitech Unifying Receiver
(RQR12.xx)
  │     License:          Proprietary
  │     Size:             56.8 kB
  │     Created:          2019-07-18
  │     Urgency:          High
  │     Vendor:           Logitech
  │     Duration:         30 seconds
  │     Flags:            is-upgrade
  │     Description:
  │     This release addresses an encrypted keystroke injection vulnerability
sent by pointing devices. The vulnerability is complex to replicate and would
require a hacker to be physically close to a target.
  │
  │     A few of Logitech's devices used to send select buttons in an
unencrypted way, and in an effort to protect against this vulnerability,
Logitech removed the feature. Affected hardware is:
  │
  │     • Wireless Mouse M335
  │     • Zone Touch Mouse T400
  │     • Wireless Mouse M545
  │     • Wireless Mouse M560
  │     • Touch Mouse M600
  │     • Touch Mouse T620
  │     • Wireless Rechargeable Touchpad T650
  │
  │     Although Logitech does not recommend it, these features may be re-
activated by keeping/downgrading the receiver to an older firmware."

I tried to do the same fixes as the original submitter, with the same
(non)results. I am using a Cinnamon Desktop Environment boot up using a a BIOS,
not UEFI setup.

So it appears that unless fwupd is re-written to add support for non-UEFI
setups, I may be stuck with this problem until some time in the future when I
try to do a fresh install using a UEFI setup, and hoping that works on my older
computer.

-- System Information:
Debian Release: 11.0
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500,
'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 5.10.0-8-amd64 (SMP w/4 CPU threads)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not
set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

ii  libelf1                0.183-1
ii  libsystemd0            247.3-6

Versions of packages fwupd recommends:
ii  bolt                               0.9.1-1
ii  dbus                               1.12.20-2
ii  fwupd-amd64-signed [fwupd-signed]  1.5.7+4
ii  python3                            3.9.2-3
pn  secureboot-db                      <none>
ii  udisks2                            2.9.2-2