Subject: Bug#998235: firefox: can not use microphone

From: TANIGUCHI Takaki <[email-masked]>
Date: Mon, 01 Nov 2021 22:06:04 +0900

Package: firefox
Version: 93.0-1+b1
Severity: normal

Dear Maintainer,

When I use microphine on Firefox, I can not use microphone and after
that Firefox hang up.

At first I found that problem on using Google meet. By the way it
happens on any site with microphone. 
I checked test site at https://mictests.com/ .

I checked USB microphone and USB headset.

-- System Information:
Debian Release: bookworm/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 5.14.0-3-amd64 (SMP w/16 CPU threads)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8), LANGUAGE=ja_JP.UTF-8
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages firefox depends on:
ii  debianutils          5.5-1
ii  fontconfig           2.13.1-4.2
ii  libatk1.0-0          2.36.0-2
ii  libc6                2.32-4
ii  libcairo-gobject2    1.16.0-5
ii  libcairo2            1.16.0-5
ii  libdbus-1-3          1.12.20-3
ii  libdbus-glib-1-2     0.112-2
ii  libevent-2.1-7       2.1.12-stable-1
ii  libffi8              3.4.2-3
ii  libfontconfig1       2.13.1-4.2
ii  libfreetype6         2.11.0+dfsg-1
ii  libgcc-s1            11.2.0-10
ii  libgdk-pixbuf-2.0-0  2.42.6+dfsg-2
ii  libglib2.0-0         2.70.0-3
ii  libgtk-3-0           3.24.30-3
ii  libnspr4             2:4.32-1
ii  libnss3              2:3.70-1
ii  libpango-1.0-0       1.48.10+ds1-1
ii  libstdc++6           11.2.0-10
ii  libvpx7              1.11.0-2
ii  libx11-6             2:1.7.2-2+b1
ii  libx11-xcb1          2:1.7.2-2+b1
ii  libxcb-shm0          1.14-3
ii  libxcb1              1.14-3
ii  libxcomposite1       1:0.4.5-1
ii  libxdamage1          1:1.1.5-2
ii  libxext6             2:1.3.4-1
ii  libxfixes3           1:5.0.3-2
ii  libxrender1          1:0.9.10-1
ii  procps               2:3.3.17-5
ii  zlib1g               1:1.2.11.dfsg-2

Versions of packages firefox recommends:
ii  libavcodec58  10:4.4.1-dmo1

Versions of packages firefox suggests:
ii  fonts-lmodern          2.004.5-6.1
pn  fonts-stix | otf-stix  <none>
ii  libcanberra0           0.30-8
ii  libgssapi-krb5-2       1.18.3-7
ii  pulseaudio             15.0+dfsg1-2

-- no debconf information

---

From: Michal Humpula <[email-masked]>
Date: Thu, 04 Nov 2021 17:58:21 +0100

Hi,

I'm observing similar issue. Mic is unresponsive on version 93 and 94. 
Version 92 from experimental works fine. Tested with empty profile.
The browser can no longer play anything (music, video, ...) after it 
starts interact with mic. Until than the video and sound play is ok.

Cheers
Michal

---

From: Tiit Pikma <[email-masked]>
Date: Fri, 5 Nov 2021 18:32:21 +0200

Hi

I have the same experience on firefox 94.0-1. Audio playback works fine 
before. Attempting to use the microphone fails and after that audio 
playback breaks with the browser hanging after a short while. I have 
tested on multiple computers and with multiple microphones (2 webcams 
and a headset).

Checking pulseaudio logs (attached) when creating a Google Meet meeting, 
Firefox only registers a playback stream named "AudioCallbackDriver" and 
no recording streams.

Regards
Tiit

---

From: Bruno Kleinert <[email-masked]>
Date: Sun, 07 Nov 2021 06:49:58 +0100

Hi,

I can confirm the same issue using pipewire-pulse 0.3.39-3 as audio
deamon on unstable/sid with both packages:

   1. firefox-esr 91.3.0esr-1
   2. firefox 94.0-1

As an intermediate workaround, chromium works (tested with chromium
93.0.4577.82-1).

Cheers,
Bruno

---

From: Rupert Swarbrick <[email-masked]>
Date: Tue, 09 Nov 2021 09:42:49 +0000

This appears to have been reported upstream at

  https://bugzilla.mozilla.org/show_bug.cgi?id=1737212

R

---

From: Tiit Pikma <[email-masked]>
Date: Mon, 15 Nov 2021 10:28:35 +0200

This is fixed for me in firefox 94.0-2, so it seems that the issue might 
have been related to #998108.

Tiit

---

From: Bruno Kleinert <[email-masked]>
Date: Wed, 08 Dec 2021 10:53:45 +0100

> As an intermediate workaround, chromium works (tested with chromium

It's fixed for me in:

   1. firefox-esr 91.4.0esr-1
   2. firefox 95.0-1

Cheers,
Bruno