I'll put my hand up for that mistake. I think the word I was looking for was "redundant", and not "ambiguous". Following the other concept of prefixing your booleans with "can" "has" and "is", your variable names should be self explanatory.
if (isSelectable === true) { ... }
versus:
if (isSelectable) { ... }
It's a shorthand method, similar to why you would use int++; instead of int = int + 1;